Resolving job termination problems

If you experience delays in the termination of an IBM® InfoSphere® DataStage® job when it is run, clear the &PH& directory.

Symptoms

Jobs take too long to terminate.

Causes

Each InfoSphere DataStage project directory contains a &PH& directory. The &PH& directory contains information about active stages that is used for diagnostic purposes. The &PH& directory is added to every time a job is run, and needs to be cleared periodically.

Resolving the problem

To clear the directory:
  1. Ensure that there are no jobs running anywhere on the system.
  2. Open the Administrator client, go to the Projects page, select the project whose file you want to clear, and click Command.
  3. In the Command Interface window, type the following command:
    CLEAR.FILE &PH&
  4. Click Execute to run the command and clear the file.