Cannot get exclusive access to the log for a job.

If you cannot get exclusive access to a log for a job, you are unable to delete the job.

Symptoms

The user deletes a job from the DataStage Designer, and receives the following error:
Unable to delete the item(s). Delete object for '\<path>\<jobname>' failed. Cannot get exclusive access to log for job <jobname> 

Causes

A lock remains on the RT_LOG file for the job.

Resolving the problem

Make sure that the job is not running. If the job is running, stop the job if possible. From DataStage Director, select the job. Then click the Job menu and select Reset. Try to delete the job again from the Designer.

If the delete still fails, manually delete the lock from uvsh with the following instructions where '$' is the OS prompt, and '>' is the uvsh prompt. That is, you do not type them.

  1. Change the directory to $DSHOME, which is ./IBM/InformationServer/Server/DSEngine by default. Source the dsenv file with the following command: $ . ./dsenv
  2. Start uvsh with the $ bin/uvsh command. In uvsh, the shift key is not needed to produce uppercase character, but it is used to produce lowercase characters. The role of the shift key is reversed from normal. As a result, copy-and-paste behaves strangely and is not useful.
  3. At the UV prompt, log on to the project. The project name is case-sensitive. Use the following command: LOGTO projectname
  4. Find out what the job description number is with the LIST DS_JOBS jobname command.
  5. List the active locks with the LIST.READU EVERY command. Check the active record locks under the Item Id column for the job name. You can also use RT_CONFIG#or RT_LOG# where # is the job description number.
  6. Write down the inode number and user number for the lock that is not a valid lock.
  7. Log in to the UV account where the UNLOCK command lives.
  8. Run the following command: UNLOCK INODE inode# USER user# ALL
  9. Type Q to logout of uvsh.
  10. Delete the job from the Designer.