Message or help information is not available

The help information for user interface (UI) pages or messages is not available.

Symptom

The user clicks on the help link to open a new window with help information for a UI page or message, but the help is not displayed. Instead, the error message file not found is displayed in the user’s web browser.

Possible cause

The help files are missing or are not readable. Or, new help files were installed and z/OSMF was not restarted. By default, the z/OSMF help files must reside at the location /var/zosmf/helps/eclipse/plugins.

System programmer response

Use the following procedure to resolve this error:
  1. Verify that symlinks exist in the /var/zosmf/helps/eclipse/plugins subdirectory. The symlinks should refer to the z/OSMF product directory, which, by default, is /usr/lpp/zosmf/V2R1).
  2. Verify that the EJBROLE resource class is defined properly; it is case sensitive.
  3. Restart the z/OSMF server, for example, through the MVS START command.

User response

No action is required.