Some of the Tivoli® Monitoring
for Tivoli Storage Manager user account
passwords might expire and cause the application to stop functioning.
You can reset any of the passwords to continue monitoring your Tivoli Storage
Manager servers.
Symptom
The following symptoms might occur
on the operating system on which a password expired:
- An authentication error can occur when you try to start the Tivoli Enterprise
Portal and log
on.
- The Warehouse Proxy agent and Summarization Pruning agent can
no longer access the WAREHOUS database. Errors for the two agents
might be displayed in the Tivoli Enterprise
Portal.
- Tivoli Common
Reporting reports
can fail to display recent historical data.
- Tivoli Common
Reporting reports
can fail to run because it cannot connect to the WAREHOUS database.
Causes
When you install Tivoli Monitoring
for Tivoli Storage Manager, several
operating system account passwords are created. Passwords are configured
during the installation. If you forget a password, or if a password
expires, you must reset the password, and then reconfigure one or
more IBM® Tivoli Monitoring services
to update the password field.
Resolving the problem
You can reset any
of the Tivoli Monitoring
for Tivoli Storage Manager passwords,
and then update the necessary services for the new password to be
accepted. The accounts that are created are described in the table.
Complete
the following steps to reset a Tivoli Monitoring
for Tivoli Storage Manager account
password and update the necessary services.
- From a command prompt window, use the passwd operating
system command to reset any of the Tivoli Monitoring
for Tivoli Storage Manager passwords.
# passwd userID
- Use the table to
reconfigure the services that are based on the user account password
that was reset.
- From the operating system, right-click .
- Expand Local Users and Groups.
- Click Users.
- Right-click the user account for which the password was reset,
and select Set Password. Enter in the new password.
- Use the information in the following table to reconfigure
the services that are based on the user account password that was
reset.
Review the
table to
determine which services need to be reconfigured.
Restriction: The
passwords for sysadmin, itmuser,
and TEPS must be the same if you plan to upgrade Tivoli Monitoring
for Tivoli Storage Manager.
Table 1. List of user IDs and corresponding services that
must be reconfigured if passwords are resetUser ID |
Action |
Description of the user ID |
sysadmin
|
After you reset this password, no other services
must be updated.
|
Default Tivoli Enterprise
Portal user ID
|
db2inst1
db2admin
|
After you reset this password, open the Manage
Tivoli Enterprise Monitoring Services window. Right-click
the following services and click Reconfigure: - Warehouse Proxy agent
- Tivoli Enterprise
Portal server
From the Windows Start menu,
click Run and type services.msc.
Find all of the DB2® services
that have Log on As as db2admin.
For each service, right-click the service, and then click Properties.
Click the Log on tab and enter in the new password.
|
Database administrator user ID
|
itmuser
ITMUser
|
After you reset this password, complete the
following tasks: - Run the DB2DataSource.exe program from install_dir\InstallITM directory.
Note: The user that is running the program must have db2admin authority to successfully update the password.
- Open the Manage Tivoli Enterprise Monitoring Services window. Right-click the following services and click Reconfigure:
- Warehouse Proxy agent
- Summarization and Pruning agent
- Tivoli Enterprise
Portal server
- Run the datasrc script to reconfigure the data source. The data source defines the connection to the WAREHOUS database from Tivoli Common
Reporting.
|
Tivoli Data
Warehouse user ID
|
TEPS
|
If this password expires, update the password.
No services need to be updated.
|
Tivoli Enterprise
Portal server database
user ID
|