Security roles are not set properly in WebSphere Application Server

On some computers, the security roles that the Watson Explorer Content Analytics Web applications require in WebSphere® Application Server are not set correctly.

Symptoms

This problem can result in an HTTP 403 Forbidden error when WebSphere Application Server is started.

Causes

On some computers, the settings for mapping security roles to user or group settings for the Everyone and All authenticated roles are cleared even if they were set during a previous installation. This problem can occur during the initial installation and potentially during Hot Fix installations.

Resolving the problem

To solve this problem, use the WebSphere Application Server administrative console to map the roles:
  1. Configure Enterprise Applications and select the ESSearchServer application.
  2. Select the option to map security roles to users and groups.
  3. Select the Everyone? and All authenticated? check boxes.
  4. Save the configuration changes.