[Servlet Error]-[action]: java.lang.NoClassDefFoundError: lotus.domino.NotesException

After clicking Apply on one of the configuration panes of the Administration page, an error occurs.

Symptoms

[Servlet Error]-[action]: java.lang.NoClassDefFoundError: lotus.domino.NotesException

Causes

The Notes.jar file was not in the IBM® WebSphere® Application Server shared library classpath.

Resolving the problem

Verify that the Notes.jar file is in the WebSphere Application Server shared library classpath:
  1. Open the WebSphere Application Server administrative console by clicking Start > Programs > IBM WebSphere > Application Server > Profiles > eDiscovery Manager application server profile > Administrative console.
  2. Expand Environment, Shared Libraries, and EDMLibraries.
  3. Confirm that the Classpath field contains an entry for the fully-qualified path to the Notes.jar file, for example: C:/Program Files/Lotus/Domino/jvm/lib/ext/Notes.jar.
  4. If there is no entry for the Notes.jar file, add one.
  5. Stop and restart the IBM eDiscovery Manager application server for your change to take effect.