Troubleshooting
Problem
User launches Controller client. User receives an error.
Symptom
An error occurred while trying to access the server
Details:
The underlying connection was closed: An unexpected error occurred on a receive.
at System.Web.Services.Protocols.WebClientProtocol.GetWebResponse(WebRequest request)
at System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters)
at Cognos.Controller.ControllerSoapHttpClientProtocol.Invoke(String methodname, Object[] parameters)
at Cognos.Controller.Proxy.Light.WSLight.CheckServerConnection(String sGuid, String sUser)
at Cognos.Controller.Direct.ServerInfoD.CheckServerConnection()
at CCR.AppContext.CheckConnectionToServer()
Cause
There are several known causes for this error.
- See separate IBM Technote #0741571 for more examples.
This Technote specifically relates to the scenario where the cause is that both of the following are true:
- Controller client configured to use SSL (HTTPS) for its communication (to the Controller application server)
- Client (and/or the application server) has been configured to disable some required SSL/TLS communication protocols.
Example:
In one real-life example, the client device has been configured so that only the following protocols are enabled:
Specifically, the following protocols were disabled:
- TLS 1.0
- TLS 1.1
Resolving The Problem
Fix:
Reconfigure all of Controller to force the use of TLS 1.2.
- TIP: For instructions, see separate IBM Technote #0883036.
Workaround:
Reconfigure the client device (plus also the application server if necessary) so that the required protocols are enabled.
Example:
In one real-life example, the solution was to reconfigure the client device so that it allowed the following protocols:
Specifically, enabling:
- TLS 1.0
- TLS 1.1
Related Information
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Document Information
Modified date:
30 April 2019
UID
swg22015415