IBM Support

Client fails to connect to server using TCP/IP, ANS7525E error message displayed

Troubleshooting


Problem

The client fails to connect to the server using the TCP/IP protocol. SSL is required by the server.

Symptom

The client was able to communicate with the server, using the TCP/IP protocol. After the same node connects to a server using shared memory, subsequent attempts to use TCP/IP fail. The following error message appears in the client error log:


    ANS7525E SSL is required by server.

Cause

Security enhancements were introduced in the IBM Tivoli Storage Manager server V7.1.8 and later and IBM Spectrum Protect V8.1.2 and later releases.

Diagnosing The Problem

When running the QUERY NODE command with the node_name format=detailed parameter, the value of Session Security parameter is TRANSitional. However, the server still requires Secure Sockets Layer (SSL) protocol. The following error appears in the activity log:


ANR1888W Session xxx for node NODE_NAME (AIX) refused - client requires SSL connection with this server. (SESSION: xxx)

Resolving The Problem

For IBM Tivoli Storage Manager Client versions earlier than V7.1.8 and IBM Spectrum Protect Client versions earlier than V8.1.2, resume the TCPIP communication by manually updating node definition:

update node node_name SESSIONSECurity=TRANSitional SSLrequired=no

For IBM Tivoli Storage Manager Client versions V7.1.8 or later and IBM Spectrum Protect Client versions V8.1.2 or later, it is mandatory to use SSL to configure client and server communication.

[{"Product":{"code":"SSEQVQ","label":"IBM Spectrum Protect"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"Client","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"7.1;7.1.3;7.1.4;7.1.5;7.1.6;7.1.7;8.1;8.1.1","Edition":"","Line of Business":{"code":"LOB26","label":"Storage"}}]

Document Information

Modified date:
17 June 2018

UID

swg22014686