IBM Support

i2 iBase missing menu items to purge and restore deleted records

Troubleshooting


Problem

i2 iBase is missing the "Purge Deleted Records..." and "Restore Deleted Records..." menu items from the Edit menu.

Cause

These menu items will be missing if the user does not have access to the Soft Delete functionality.

Resolving The Problem

  1. Follow the procedures below to provide access to the Soft Delete functionality and restore the menu items.
  2. Open iBase Designer and logon. You do not need to connect to a database.
  3. Select Security-->Security Manager.
  4. In Security Manager, under the "Users" tab, expand your user and make a note of which groups it belongs to. In the example below, SYSADMIN belongs to the group "Super Users".
  5. Close the Security Manager,
  6. Select Security-->System Commands Access Control.
  7. Select the group that your user belongs to, and scroll down until you see the "Soft Delete" checkbox.
  8. If "Soft Delete" is checked, then your user is denied access to the commands. Uncheck the box.
  9. Exit System Commands Access Control, and exit iBase Designer.
  10. Open iBase User and confirm that your menu options are restored.

[{"Product":{"code":"SSXW43","label":"i2 iBase"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"--","Platform":[{"code":"PF033","label":"Windows"}],"Version":"8.9.11;8.9.11.1;8.9.11.2","Edition":"Edition Independent","Line of Business":{"code":"LOB24","label":"Security Software"}}]

Document Information

Modified date:
16 June 2018

UID

swg22014672