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ANR0530W transaction failed errors when running node replication.

Troubleshooting


Problem

IBM Spectrum Protect node replication can fail with ANR0530W messages in server activity log

Symptom

In the server activity log you may see the following messages indicating that Node replication failed:


ANR0530W Transaction failed for session 149821 for node NODE1 internal server error detected.
ANR9999D_3095886799 HandleShortCircuitCodes

ANR9999D_0216910773 BfPrepareNew(bfcreate.c:4652) Thread<384757>:
                    tbRegisteredOpen failed, rc=1115

ANR1181E bftxn.c(509): Data storage transaction 0:59856841 was aborted.
ANR0532W smrepl.c(963):Transaction 12345 was aborted for node NODE1
     

In the db2diag.log you may see the following message:

YYYY-MM-DD-HH.MM.SS                                LEVEL: Error
PID     : 25480           TID  : 47011587942720PROC : db2sysc 0
INSTANCE: YOURDB2         NODE : 000           DB   : TSMDB1
EDUID   : 260             EDUNAME: db2loggr (TSMDB1) 0
FUNCTION: DB2 UDB, data protection services,
sqlpScanTranTableForLowTran, probe:550
MESSAGE : ADM1541W  Application "dsmserv" with application
handle "0-13783" and application id
"*LOCAL.yourdb2.131202194651" executing under authentication id
"YOURDB2  " has been forced off of the database for violating
database configuration parameter NUM_LOG_SPAN (current value
"231"). The unit of work will be rolled back.

Cause

A long-running transaction had spanned across the maximum number of active logs and, thus, in an effort to prevent the active log from becoming full, DB2 terminated the transaction.

Resolving The Problem

There can be several reasons for this condition to occur.
.
1) The problem can be seen when the active log is undersized. If this is the case, increasing the size of
the active log will resolve this problem.

2) If your active log is already at the maximum permitted size of 128GB then there is probably too much
concurrent database activity or running transactions that are taking a unusually long time to complete.
For example, you may see many replication sessions (from other servers) that are running for 24 hours
or more. These long running sessions could pin the active log and cause the problem.

To prevent these long running replication sessions from pinning the active log, either reduce the
amount of data that gets moved or the amount of time that the replication sessions run.

Also, if you have multiple servers running node replication at the same time, reschedule some of the
replication processes to reduce the work load.

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Product Synonym

TSM

Document Information

Modified date:
17 June 2018

UID

swg22012961