IBM Support

Data Protection for SAP HANA restore fails with Error -50

Troubleshooting


Problem

ANS1017E RC-50 failure when performing a Data Protection SAP HANA restore

Symptom

The Data Protection for SAP HANA backup.log shows RECOVERY RECOVER DATA finished with an error.

Cause

Slow or unstable network data transfer between IBM Spectrum Protect server and Data Protection for SAP HANA, and the session is timing out on the IBM Spectrum Protect server side.

Diagnosing The Problem

The IBM Spectrum Protect server activity log may show following error:

ANR8216W Error sending data on socket 73372. Reason 10053.

The server instrument trace shows a slow Network Send.

Resolving The Problem

The TCPWINDOWSIZE value should be adaptable for the network performance. To achieve better performance, set the TCPWINDOWSIZE in the client option file used by Data Protection for SAP HANA to a value of zero:

TCPWINDOWSIZE 0

When you set the value to 0, the server uses the default window size that was set by the operating system.

[{"Product":{"code":"SSER83","label":"IBM Spectrum Protect for Enterprise Resource Planning"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"Data Protection for SAP HANA\u00ae","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"7.1.3;7.1.4;7.1.6;8.1.0;8.1.1;8.1.4","Edition":"","Line of Business":{"code":"LOB26","label":"Storage"}}]

Product Synonym

TSM

Document Information

Modified date:
17 June 2018

UID

swg22012308