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Array index out of bound exception when we provide wrong syntax in rootassets

Troubleshooting


Problem

Discover Rest API uses a standard ErrorResponse formatter to format the error message. Currently, if the input validation in the discover service catches an invalid value in the input, it throws an appropriate exception which can be seen in the DA UI in the proper format. However, if the validation succeeds and the actual import fails, there will not be any prompt provided to DA UI. In IMAM GUI, we can check the status of the discover by going to the appropriate import area. Also, when the user provides a non-existing schema in a proper format, the DA UI will not be displayed with any information regarding it. It will not even be visible in IMAM GUI because we cannot import anything out of it

Symptom

Array index out of bound exception when we provide wrong syntax

Cause

Incorrect usage and incomplete error message

Diagnosing The Problem

if the user provides an invalid schema name in valid format then the import area will get created with failed import to staging. In that scenario with asynchronous import the user will get the list of import areas(at least on the cli) and we can ask user to check the individual import areas for import status

Resolving The Problem

Correct the syntax in the JSON file to have the correct rootAssets

[{"Product":{"code":"SSZJPZ","label":"IBM InfoSphere Information Server"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"IBM InfoSphere Metadata Asset Manager","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF016","label":"Linux"},{"code":"PF033","label":"Windows"}],"Version":"11.7.0.0;11.7","Edition":"All Editions","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Historical Number

IMAM/553

Document Information

Modified date:
16 June 2018

UID

swg22011749