IBM Support

Invalid Login Response when Single Sign On (SSO) is enabled in Cognos Analytics

Troubleshooting


Problem

When SSO is enabled for Cognos Analytics, the error "Invalid Login Response" is returned".

Symptom

Invalid Login Response trying to access Cognos with SSO enabled

Cause

Configuration setting in IIS

Environment

IIS

Diagnosing The Problem

Invalid Login Response trying to access Cognos with SSO enabled

Resolving The Problem

1. Click on the alias (for example ibmcognos)

2. Double click on the configuration editor

3. Under system.webServer select httpErrors

4. Set the existing Response value to pass through and select apply

5. Launch a command prompt window and execute an 'issreset" -Note will restart the web service completely

5.a To reset only the application being used by Cognos

5.b select application pools

5.c select the application pool being used by Cognos

5.d select stop and then start

6. You should be able to login now

[{"Product":{"code":"SSTSF6","label":"IBM Cognos Analytics"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Administration and Configuration v11x","Platform":[{"code":"PF033","label":"Windows"}],"Version":"11.0","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg22004766