IBM Support

"'Controller_ExcelLink' has fired an exception" ... "System.NullReferenceException ... ConvertToXlMethodInfos" when enabling Excel link

Troubleshooting


Problem

User launches Excel. The Controller add-in is not visible - Specifically, the Controller COM addin does not successfully load. If the user tries to activate the Controller Excel link, and error appears.

Symptom

After launching Excel, if you try to activate the Controller Excel link, the following message is shown:

Date and Time: 4/5/2017 4:33:14 PM
Machine Name: PCNAME
IP Address: ::1
Current User: DOMAIN\username

Application Domain: C:\Program Files (x86)\IBM\IBM Cognos Controller\
Assembly Codebase: file:///C:/Program Files (x86)/IBM/IBM Cognos Controller/AddinExpress.MSO.2005.DLL
Assembly Full Name: AddinExpress.MSO.2005, Version=7.5.4072.2005,
Culture=neutral, PublicKeyToken=4416dd98f0861965
Assembly Version: 7.5.4072.2005

Exception Source: AddinExpress.MSO.2005
Exception Type: System.NullReferenceException
Exception Message: Object reference not set to an instance of an object.
Exception Target Site: ConvertToXlMethodInfos

---- Stack Trace ----
AddinExpress.MSO.ADXExcelMethodInfo.ConvertToXlMethodInfos
(methodInfos As List`1, functions As List`1)
AddinExpress.MSO.2005.DLL: N 0005 (0x5) IL
AddinExpress.MSO.ADXXLLModule.RegisterMethods(methods As List`1)
AddinExpress.MSO.2005.DLL: N 0000 (0x0) IL
AddinExpress.MSO.ADXXLLModule.autoOpen()
AddinExpress.MSO.2005.DLL: N 0781 (0x30D) IL

Cause

There are several possible causes for similar "'Controller_ExcelLink' has fired an exception" errors.

  • TIP: See separate IBM Technote #2004500 for more examples.

This Technote specifically relates to the scenario where the cause is that something (for example a Microsoft patch) has corrupted the end user's Windows user profile, relating to the Excel add-in.

Environment

Example:

In one real-life customer example, initially everything was working OK. Then the customer applied a Microsoft Office patch (in order to patch Excel 2013 from 15.0.4875.1001 to 15.0.4911.1002).

  • After doing this, the problem occurred.

Resolving The Problem

Fix:

Reset the 'bad' end user's Excel registry key: HKEY_CURRENT_USER\Software\Microsoft\Office\Excel

Steps:

1. Logon to the client device as the 'bad' user

2. Click "START - RUN" and type in: REGEDIT

3. Browse to here: HKEY_CURRENT_USER\Software\Microsoft\Office\Excel

4. Rename 'HKEY_CURRENT_USER\Software\Microsoft\Office\Excel' to: HKEY_CURRENT_USER\Software\Microsoft\Office\Excel.BAD

5. Test.

Workaround:

Method #1

Logon to the same client device, but using a different Windows username (and password).

Method #2

Reset the 'bad' end user's Windows user profile.

Steps:

Ask your I.T. department for advice on how best to reset your Windows user profiles.

  • For example, take a backup copy of all documents/files first, and then delete the Windows user profile.

[{"Product":{"code":"SS9S6B","label":"IBM Cognos Controller"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Controller","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.2.1","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg22004440