IBM Support

Null error while running Security Wizard in ACCE (CPE 5.2.1.6) on Weblogic 12.1.3 and its workaround

Troubleshooting


Problem

The Security Script Wizard on Administration Console for Content Platform Engine (ACCE) shows a null error on Weblogic 12.1.3 for CPE 5.2.1.6. This technote guides you with a workaround how to solve the problem.

Symptom

The Security Script Wizard on Administration Console for Content Platform Engine (ACCE) throws a null error on Weblogic 12.1.3.

Cause

Incompatible Javascript Engine (Rhino) version bundled with WebLogic 12.1.3 causes the problem.

Environment

WebLogic Appserver 12.1.3 and CPE 5.2.1.6

Resolving The Problem

Do the following steps:

1. Stop WebLogic server.
2. Using 7-zip, open Engine-WL.ear that is deployed on the WebLogic server, typically located at
- "C:\Program Files\IBM\FileNet\ContentEngine\tools\configure\profiles\CPE 5216\ear"
3. Extract js.jar from Engine-WL.ear\APP-INF\lib\ to temporary folder on the disk.
4. Add js.jar to Engine-WL.ear\acce_navigator.war\WEB_INF\lib\
5. Replace the content in weblogic.xml file located in Engine-WL.ear\acce_navigator.war\WEB_INF\ with following:


6. Close the 7-zip file and save the changes into the Engine-Wl.ear.
7. Delete WebLogic cache.
8. Start the Weblogic server.
9. Deploy the updated Engine-wl.ear file.
10. Restart WebLogic server and run the Security Script wizard.

[{"Product":{"code":"SSNVNV","label":"FileNet Content Manager"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Content Engine","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"5.2.1","Edition":"All Editions","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
17 June 2018

UID

swg22003723