IBM Support

Troubleshooting the ARS0000E message on z/OS

Troubleshooting


Problem

ARS0000E can be caused by one of several issues.

Symptom

ARS0000E message

Cause

The most likely causes are the MAXMMAPAREA limit or a region limit.

The cause might also be REGION=0M not specified on both the JOB card and the STEP.

Another cause might be mismatched levels between the LOADLIB and the HFS files, such as having a V10.0 SARSLOAD and a V10.5 HFS.

The cause might also be a bad path to the ICU .dat file.

Environment

Content Manager OnDemand on z/OS

Diagnosing The Problem

Here is the JCL to take an LE trace:
 
Add the LE parms and -v option as shown below to your ARSSOCKD jobcard
for the failing task:                                              
                                                                      
                                                                      
//ARSSOCKD EXEC PGM=ARSSOCKD,REGION=0M,TIME=NOLIMIT,                  
//        PARM='TRACE(ON,15M,,LE=1)/-S -I ARSRBOT -v'                
 
To tell what level of SARSLOAD is in use, an LE trace will show the following:
58 = 10.1 or 10.5 (ICU 5.8)
 
Also, you can browse ARSSOCKD for umtx_lock.  Different versions of Content Manager OnDemand will have _48, _53, or _58. 
 
 
The LE TRACE(ON,1M,,LE=1) will capture the failure if it's in MAXMMAPAREA.
If the failure is not in MAXMMAPAREA, the ARSBIN DD should be examined.
The parent directory of bin/ should have a locale/ directory, and in that locale/ directory is a .dat file, whose name depends on the version of Content Manager OnDemand being executed. For V10.1 or V10.5, it's icudt58e.dat. The number corresponds to the version of ICU that that particular version of Content Manager OnDemand is built with.

   

Example of setting the LE trace and diagnosing a MAXMMAPAREA limitation:




//ARSSOCKD EXEC PGM=ARSSOCKD,REGION=0M,TIME=NOLIMIT,
// PARM='
TRACE(ON,15M,,LE=1)/-S -I ARCHIVE -v'  

Then after the ARSSOCKD failure, search on "mmap" which shows this:


 +1FC010    Member ID.... 03    Flags..... 000000    Entry Type..... 00000005
           +1FC018    A49799A5 6D948197 C6899385 6DF4F86D  8199A2A7 88404040 40404040 40404040  |uprv_mapFile_48_arsxh           |
           +1FC038    60606E4D F0F2F9F5 5D409494 81974D5D  40404040 40404040 40404040 40404040  |-->(0295) mmap()                |
           +1FC058    40404040 40404040 40404040 40404040  40404040 40404040 40404040 40404040  |                                |
           +1FC078    40404040 40404040                                                         |                                |

           +1FC080    Time 05.05.22.187990    Date 2016.07.23    Thread ID... 232DE20000000000
           +1FC090    Member ID.... 03    Flags..... 000000    Entry Type..... 00000006
           +1FC098    4C60604D F0F2F9F5 5D40D9F1 7EF2F6F4  C5F2F3F7 F040D9F2 7EC1F3C2 F3F2C4F0  |<--(0295) R1=264E2370 R2=A3B32D0|
           +1FC0B8    C340D9F3 7EC6C6C6 C6C6C6C6 C640C5D9  D9D5D67E F0F0F0F0 F0F0F7C3 40C5D9D9  |C R3=FFFFFFFF ERRNO=0000007C ERR|
           +1FC0D8    D5D6F27E F0F7F3F6 F0F3F4F4 00000000  00000000 00000000 00000000 00000000  |NO2=07360344....................|
           +1FC0F8    00000000 00000000        
bpxmtext 07360344

indicates that the ERRNO2=07360344 says

BPXGYVRT 09/07/11
JRMmapStgExceeded: The system-wide limit on the amount of memory consumed by
memory mapped areas is exceeded

Action: Try again later. If the problem persists, either reduce the size of
the memory mapping request, or request the system administrator to increase
the MAXMMAPAREA parameter of the BPXPRMxx parmlib member.
***

     

The region problem could be because of running under TSO rather than in batch, which would cause the region to inherit the size of the TSO session.

Note: ICU will look in different places for its .dat, and the trace will show stat() failures are due to it searching various locations. If the trace gets past all those stat()s,most likely you'll see an mmap() failure. It's also possible a random malloc() could fail if the region was limited.


Also check the paths to the ARS.CFG and ARS.INI configuration files.

Resolving The Problem

Try REGION=0M everywhere first since it is the easiest change to make.

Then increase MAXMMAPAREA. This change can be done dynamically.

Then take other action as appropriate.

[{"Type":"MASTER","Line of Business":{"code":"LOB10","label":"Data and AI"},"Business Unit":{"code":"BU048","label":"IBM Software"},"Product":{"code":"SSQHWE","label":"Content Manager OnDemand for z\/OS"},"ARM Category":[{"code":"a8m0z0000001gP1AAI","label":"technote"}],"ARM Case Number":"","Platform":[{"code":"PF035","label":"z\/OS"}],"Version":"All Versions"}]

Document Information

Modified date:
12 April 2024

UID

swg22003403