IBM Support

db2iupdt ERROR: The specified instance "instance_name" does not exist.

Troubleshooting


Problem

db2ilist does not return instance.

Symptom

db2iupdt fails with
"ERROR: The specified instance "instance_name" does not exist. Specify an existing instance name.
ERROR: The "db2iupdt" command failed. Ensure that errors reported in the log file are fixed, then rerun the command."


db2ilist returns blank.

Cause

more than one global.reg file, DB2 picking the wrong file.

Diagnosing The Problem

db2greg -dump shows correct entries for the instance and installation.
db2ilist shows no output matching with db2greg -dump




Resolving The Problem

find / -name global.reg -print 2>/dev/null
Check if there are any global.reg files that might be being picked by the tool

Example:
db2greg -dump
I,DB2,10.5.0.7,db2inst1,/db2/db2inst1/sqllib,,1,0,/db2/db2_software/v10.5_fp7,,
V,DB2GPRF,DB2INSTDEF,db2inst1,/db2/db2_software/v10.5_fp7,
S,DB2,10.5.0.7,/db2/db2_software/v10.5_fp7,,,7,0,,1478203317,3

xxx]$db2ilist

xxx]$


xxx]$ find / -name global.reg -print 2>/dev/null

/var/db2/global.reg
/db2/db2_software/v10.5_fp7/global.reg

mv /db2/db2_software/v10.5_fp7/global.reg /db2/db2_software/v10.5_fp7/global.reg.bak
export DB2_GLOBAL_REG_PATHNAME=/var/db2/global.reg

xxx]$db2ilist

xxx]$ db2inst1

[{"Product":{"code":"SSEPGG","label":"Db2 for Linux, UNIX and Windows"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"--","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"}],"Version":"9.8;9.7;9.5;10.1;10.5;11.1","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
16 June 2018

UID

swg22000229