IBM Support

Upgrading to latest ILMT version on Windows failed with Fixlet Exit Code: 41

Question & Answer


Question

Using the "Upgrade to the latest version of IBM License Metric Tool 9.x" to upgrade the ILMT to v9.2.4.x on Windows failed with exit code 41.

Cause

The Server.log filled with this type of error (Access is denied) when trying to rename the E:\IBM\LMT\wlp folder.


2016:09:13-02:01:30 - dbg - com.ibm.license.mgmt.install.ia.configuration.Action.run - Backup the server directory : thread start 63
2016:09:13-02:01:30 - dbg - com.ibm.license.mgmt.install.ia.configuration.Action.run - Update JRE : thread stop 62
2016:09:13-02:01:30 - dbg - com.ibm.license.mgmt.install.ia.util.ExecuteCmd.execute - Executing command: [cmd.exe] [/c] [move] [/Y] [E:\IBM\LMT\wlp] [E:\IBM\LMT\wlp_9.2.2.0]
2016:09:13-02:01:30 - dbg - com.ibm.license.mgmt.install.ia.util.ExecuteCmd.waitFor - timeot = 0 means wait indefinitely
2016:09:13-02:01:31 - dbg - com.ibm.license.mgmt.install.ia.util.ExecuteCmd.logResult - Command completed --------------------------
2016:09:13-02:01:31 - dbg - com.ibm.license.mgmt.install.ia.util.ExecuteCmd.logResult - return Code 1
2016:09:13-02:01:31 - dbg - com.ibm.license.mgmt.install.ia.util.ExecuteCmd.logResult - Stdout 0 dir(s) moved.
2016:09:13-02:01:31 - dbg - com.ibm.license.mgmt.install.ia.util.ExecuteCmd.logResult - Stderr Access is denied.
2016:09:13-02:01:31 - dbg - com.ibm.license.mgmt.install.ia.util.ExecuteCmd.logResult - --------------------------------------------

Even attempted to manually shutdown the ILMT server service and manually execute the upgrade locally using "LMT-server-9.2.4.0-20160615-1904-windows-x86_64.zip" package, it still failed with the same error.

Also attempted to manually rename that E:\IBM\LMT\wlp folder from a MS DOS window, same error.

Answer

Regarding what is still holding up or using the E:\IBM\LMT\wlp folder, the best way to address this issue:

1) Go to Windows Services panel and change the IBM License Metric Tool service startup option from Automatic to Manual startup.

2) Reboot the Windows server.

3) After it is rebooted, restart the upgrade process again via Fixlet or manually perform the upgrade locally on this Windows server. This will fix the issue.

Note: ensure to change back the IBM License Metric Tool service back to Automatic startup after the upgrade is completed.

[{"Product":{"code":"SS8JFY","label":"IBM License Metric Tool"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"--","Platform":[{"code":"PF033","label":"Windows"}],"Version":"9.1;9.2","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
26 April 2021

UID

swg21990672