IBM Support

"AAA-AUT-0013 The user is already authenticated in all available namespaces" when launching Controller, caused by 'spaces' in between entries inside 'User Groups'

Troubleshooting


Problem

User launches Controller. User receives error message.

Symptom

      AAA-AUT-0013
      The user is already authenticated in all available namespaces.

If the user clicks OK, user gets a second error:

The user currently logged in is not authorized to use this method.

Cause

There are several known causes for similar symptoms.

  • TIP: For more examples, see separate IBM Technote #1346138.

This Technote specifically relates to the scenario where the cause is that the administrator has entered an extra 'space' after the comma, inside the section 'Server Authentication' - User Groups'.

Example:
Imagine a scenario where the settings were as follows:

User Groups: System Administrators, Controller Users, Controller Administrators

Resolving The Problem

Make sure that there is not a space either side of the 'comma'.

Steps:
1. Logon to the Controller application server
2. Launch 'Controller Configuration'
3. Open the section 'Server Authentication'
4. Modify the section 'User Groups' to have no 'spaces' before/after the commas.

Example:
System Administrators,Controller Users,Controller Administrators

5. Save changes
6. Test.

[{"Product":{"code":"SS9S6B","label":"IBM Cognos Controller"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Controller","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.2.1","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg21988695