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'HRESULT: 0x80010105 (RPC_E_SERVERFAULT))' error when click 'X' button (to launch Controller Excel link), triggered by incompatible third-party Excel Add-in

Troubleshooting


Problem

User launches the 'main' Controller client (CCR.EXE). User then clicks the green 'X' button (to launch the 'Controller Link'). An error appears.

Symptom



English:
The server threw an exception. (Exception from HRESULT: 0x80010105 (RPC_E_SERVERFAULT))

Cause

There are several possible causes for similar errors.

  • TIP: See separate IBM Technote #1574387 for more examples.

This Technote specifically relates to the scenario where the cause is that the user's client PC has an incompatible third-party (non-IBM) Excel add-in installed.

Example:
In one real-life example, the end user had the 'Foxit PDF Reader' Excel add-in installed/enabled

Resolving The Problem

Disable the third-party (non-IBM) Excel addin.

[{"Product":{"code":"SS9S6B","label":"IBM Cognos Controller"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Controller","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.2.1","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg21987136