IBM Support

"CM-CFG-5024 Content Manager is unable to update the content store database schema from version "7.002" to "7.0027" because it cannot access the upgrade file(s) "dbupgrade7*-to-*_mssqlserver.sql"." trying to upgrade Controller

Troubleshooting


Problem

Customer is trying to upgrade Controller to a later version. As part of this, the administrator has just finished installing the Controller server software. Afterwards, the administrator launches 'Cognos Configuration' and clicks 'Start'. The IBM Cognos service does not start. An error appears.

Symptom

English:

[Start Service]
11:31:29, 'LogService', 'StartService', 'Success'.
11:31:30, CAF-WRN-0010 CAF input validation enabled.
11:31:30, CAF-WRN-0021 CAF Third Party XSS checking disabled.
11:32:57, CM-SYS-2211 The Content Manager internal consistency check is complete.
11:32:56, CM-SYS-2210 The Content Manager internal consistency check started.
11:32:57, CM-CFG-5063 A Content Manager configuration error was detected while connecting to the content store. CM-CFG-5024 Content Manager is unable to update the content store database schema from version "7.002" to "7.0027" because it cannot access the upgrade file(s) "dbupgrade7*-to-*_mssqlserver.sql".
11:32:57, 'ContentManagerService', 'StartService', 'Failure'.

11:32:57, 'ContentManager', 'getActiveContentManager', 'Failure'.
DPR-CMI-4006 Unable to determine the active Content Manager. Will retry periodically.


German:

[Start Service]
16:28:51, 'LogService', 'StartService', 'Success'.
16:28:51, CAF-WRN-0010 CAF-Eingabeprüfung ist aktiviert.
16:28:51, CAF-WRN-0021 CAF-Prüfung für XSS anderer Anbieter ist inaktiviert.
16:30:10, 'ContentManagerService', 'StartService', 'Failure'.

16:30:10, CM-SYS-2210 Die interne Konsistenzüberprüfung des Content Managers wurde gestartet.
16:30:10, CM-CFG-5063 Beim Herstellen einer Verbindung zum Content Store wurde ein Content Manager-Konfigurationsfehler gefunden. CM-CFG-5024 Content Manager kann das Content Store-Datenbankschema nicht von Version '7.002' auf '7.0027' aktualisieren, weil kein Zugriff auf die Aktualisierungsdatei(en) 'dbupgrade7*-to-*_mssqlserver.sql' besteht.
16:30:10, CM-SYS-2211 Die interne Konsistenzüberprüfung des Content Managers ist abgeschlossen.
16:30:11, 'ContentManager', 'getActiveContentManager', 'Failure'.DPR-CMI-4006 Der aktive Content Manager kann nicht festgestellt werden. Es werden regelmäßige Neuversuche durchgeführt.
<.....>
16:30:46, 'SACamSrvc', 'StopService', 'Success'.
16:30:46, 'LogService', 'StopService', 'Success'.

[Start Service]
[ ERROR ] CFG-ERR-0103 Unable to start IBM Cognos service.
Execution of the external process returns an error code value of '-1'."

English:
CM-CFG-5063 A Content Manager configuration error was detected while connecting to the content store. CM-CFG-5024 Content Manager is unable to update the content store database schema
from version "7.002" to "7.0026" because it cannot access the upgrade file(s) "dbupgrade7*-to-*_db2.sql".

Cause

Defect in the Cognos BI engine (bundled with the Controller product.

More Information:
Each version of Controller is bundled with a 'runtime' (basic engine) version of Cognos BI.

  • The version of the Cognos BI engine varies depending on the version of Controller

For example, Controller 10.2.1 FP4 is bundled with Cognos BI version CRNSRVR-AW64-ML-RTM-10.2.5100.173-0
  • This is a 'special' version of Cognos BI 10.2.1/10.2.2

Some versions of Cognos BI contain a defect (reference APAR PI56412) which causes this problem.

Environment

The problem could potentially affect several environments.

  • For example, it has been seen when upgrading from Controller 10.2.0 FP1 IF4 to 10.2.1 FP4

Resolving The Problem

Before performing the upgrade:

(a) Perform a 'full deployment export' of the content store.

After the upgrade has been performed:

(b) Create a brand new (blank) content store database

(c) Import the information that was exported earlier [in step (a)].

Steps:


==================================================
BEFORE UPGRADING YOUR SERVER (TO THE LATER VERSION OF CONTROLLER)
==================================================

0. Obtain some downtime (no users in the system)
1. Launch Cognos Connection (URL: servername/ibmcognos)
  • If prompted, choose 'Administer IBM Cognos content':


2. Click "Configuration" then 'Content Administration'

3. Click 'New Export':


4. Specify a name for the package, for example:


5. Choose 'Select the entire Content Store'
6. Tick 'Include user account information':


7. Choose/edit the encryption password:


8. Navigate through the wizard, for example:


===============================
TIP: This process has created a new deployment file (in a ZIP format).
  • Typically it will created the file here: C:\Program Files\ibm\cognos\ccr_64\deployment

===============================

9. Launch 'Cognos Configuration' and stop the Cognos BI service:


10. As a precaution, create a backup of your current contentstore database
  • For example, if using Microsoft SQL then use Microsoft SQL Management Studio to create a .BAK backup file

11. Choose whether you want to:
    (a) Delete the current contentstore database, and create a brand-new database with the same name
    or (b) or simply create a brand-new contentstore database with a different name.

==================================================
If you prefer (a) then:
  • Delete the current Content Store database (for example, by using SQL Management Studio)
  • Re-create a brand-new database, with the same name as the previous database
==================================================
If you prefer (b) then:
  • Create a brand-new database with a different name as the original ContentStore database
  • Open the section 'Content Manager / Content Store' and modify the setting for 'Database Name', so that it points to the new database:
  • Update your documentation (and most importantly) your backup plans to ensure that the new database is backed up

==================================================
NOW UPGRADE YOUR SERVER TO THE LATER VERSION OF CONTROLLER
==================================================

12. After the upgrade has finished, start the Cognos BI service:


13. Launch Cognos Connection (URL: servername/ibmcognos)
  • If prompted, choose 'Administer IBM Cognos content':


14. Click "Configuration" then 'Content Administration'

15. Click 'New Import':


16. Choose the export that was created earlier:


17. Follow the prompts to import the contents of your export (created previously).
  • TIP: You will need to know the encryption password

18. Choose to import everything:


19. Test.

[{"Product":{"code":"SS9S6B","label":"IBM Cognos Controller"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Controller","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.2.1","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg21985447