IBM Support

"Your current security settings do not allow this file to be downloaded" when changing Standard Report to a PDF file

Troubleshooting


Problem

User runs a Standard Report. This appears correctly (in HTML). User now changes 'Select Format' (the output format) to be 'PDF'. A message appears.

Symptom


Security Alert
Your current security settings do not allow this file to be downloaded.

After clicking OK, the screen simply shows a white/blank screen:


Cause

End user's Windows profile has its Microsoft Internet Explorer settings configured to block downloads from the Controller Report Server (typically the application server) website.

Resolving The Problem

Modify the Internet Explorer settings to allow downloads from the Controller Report Server (typically the application server).


TIP: There are many different potential combinations of zones/settings that will work. However, one sensible suggestion is to:
  • Configure the Controller application/web server to be inside the 'Trusted' zone
  • Configure the trusted zone to have 'Medium-Low' security
  • Ensure that the 'trusted zone' is configured to allow HTTP (instead of only HTTPS)

Steps:


See separate IBM Technote 1984087.

[{"Product":{"code":"SS9S6B","label":"IBM Cognos Controller"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Controller","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.2.1","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg21983721