IBM Support

Tivoli Storage Manager サーバー起動時にANR1820E で起動に失敗する

Troubleshooting


Problem

"restore db"実行後、Tivoli Storage Manager サーバーのフォアグラウンドでの起動時にANR1820Eが出て起動に失敗します。

Symptom

"restore db"は成功しました。その後、Tivoli Storage Manager サーバーのフォアグラウンドでの起動時にANR1820Eが出て起動に失敗します。


ANR0162W 補足データベース診断情報: -1:08004:-30061 ([IBM][CLI Driver] SQL30061N データベース別名またはデータベース名 "TSMDB1" が、 リモート・ノードで見つかりません。 SQLSTATE=08004).
ANR1820E サーバーは、TCP/IP ポート 51500 を使用したデータベース・マネージャーへの接続ができませんでした。

Cause

このエラーメッセージは、DB2の通信で利用する TCP/IPポート 51500 が既に使われていることを示します。

Diagnosing The Problem

普通、"restore db"のあと、Tivoli Storage Manager サーバーは自動的にシャットダウンされ、それに引き続いてDB2も停止されます。

しかし、何らかの理由でDB2が停止しなかったり、シャットダウンが完了しないことがあります。この時、DB2は当該TCP/IPポートを使用したまま起動しています。

"サービス"(Windows)、あるいは"ps -ef”(他のOS)で、DB2プロセスが起動しているか確認できます。

Resolving The Problem

インスタンスオーナーのIDで、OSのコマンドプロンプトから以下のコマンドを実行ください。

    db2 force application all
    db2 stop

コマンド完了後、Tivoli Storage Manager サーバーをフォアグラウンドでの起動し、起動されること、リストア後のステップが実行されることを確認してください。

Related Information

[{"Product":{"code":"SSSQWC","label":"Tivoli Storage Manager Extended Edition"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"Server","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF016","label":"Linux"},{"code":"PF033","label":"Windows"}],"Version":"All Supported Versions","Edition":"All Editions","Line of Business":{"code":"LOB26","label":"Storage"}}]

Document Information

Modified date:
17 June 2018

UID

swg21983550