IBM Support

HTTP 503 service unavailable error in IBM Content Collector for SAP

Troubleshooting


Problem

Getting HTTP 503 service unavailable error in IBM Content Collector for SAP (ICCSAP)

Symptom

HTTP 503 Service Unavailable.

Cause

The error may be caused by different reasons.
One of the reasons is that the P8 agent is taking too long and so it is unable to keep up with the incoming requests.

Environment

IBM Content Collector for SAP
IBM FileNet P8 repository

Diagnosing The Problem

A job is submitted from SAP and it fails with http 503 service unavailable error.
If you resubmit the job later, it completes successfully without errors.

Resolving The Problem

There are two things you can start looking at:

  • Try increasing the number of P8AGENTS and WEBDPS in archint.ini
  • Ensure the SAPDocID custom property is indexed in FileNet P8.
    In FileNet Enterprise Manager (FEM) or Administrative Console for Content Engine (ACCE), go to the properties of your document class.
    Property Definitions > Edit > Indexed > Set/Remove

If problem persists, contact IBM support for further assistance,

[{"Product":{"code":"SSRW2R","label":"IBM Content Collector for SAP Applications"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"--","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"4.0.0;4.0.0.1","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
17 June 2018

UID

swg21982779