IBM Support

"Error launching menu item "Controller Link" ... Cannot run the macro 'cc.CompareDb'" caused by missing Microsoft Office components (on the client device)

Troubleshooting


Problem

User launches the main Controller client (CCR.EXE). User clicks the green 'X' (to launch the Controller link). Excel starts to load. After a few seconds, an error appears.

Symptom


Error Launching menu item "Controller Link"
Error Details
Cannot run the macro 'cc.CompareDb'. The macro may not be available in this workbook or all macros may be disabled.

Cause

There are several possible causes for this error.

  • TIP: For more examples, see separate IBM Technote #1971878.

This Technote specifically relates to the scenario where the cause is that the client device does not have all the required Microsoft Office components installed.

Example:
In one real-life example, the end user's device did not have the following Office 2010 component installed:
  • Office Shared Features\Visual Basic for Applications

Diagnosing The Problem

Inside Excel, the Controller add-in does not register itself correctly.

  • Specifically, its name is (incorrectly) shown as "Adxloader.Controller.Excellink":

Resolving The Problem

Modify the end user's client device so that the required features (for example 'Office Shared Features\Visual Basic for Applications') are enabled/installed/registered.

Example

In one real-life example, the solution was to re-run the Office 2010 installation routine, and add the following missing component:


[{"Product":{"code":"SS9S6B","label":"IBM Cognos Controller"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Controller","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.2.1","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg21981002