IBM Support

User Java application running under CICS as a transaction is failing to connect to Content Manager for z/OS library server.

Troubleshooting


Problem

When trying to connect to Content Manager on z/OS the user logging onto the users CICS Java application is failing with Logon is denied by CM: User XXXXXXX Database connect ID YYYYYYYY Password is empty Server allow trusted logon flag 0 Ignore trust logon option 0

Symptom

Logon is denied error is in the library server log and customer gets logon failure.

Cause

The Authid used on the bind plan for the CICS transaction program was not defined to CM or RACF and was not configured correctly.

Environment

z/OS and CICS.

Diagnosing The Problem

Look in library server log and find logon denied error.

Resolving The Problem

The fix for this is to -
1) added the AUTHID assigned by the CICS TRAN as both a ICM UID and
ICM DB Connect ID
2) remove ICM Amin privilege from ICM UIDs that will run CICS TRAN;
3) add UserDBConnect or UserDBTrustedConnec privileges ICM UIDs that
will run CICS TRAN.

[{"Product":{"code":"SSLQWS","label":"Content Manager for z\/OS"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"CICS","Platform":[{"code":"PF035","label":"z\/OS"}],"Version":"Version Independent","Edition":"All Editions","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
14 October 2019

UID

swg21980660