Troubleshooting
Problem
When trying to connect to Content Manager on z/OS the user logging onto the users CICS Java application is failing with Logon is denied by CM: User XXXXXXX Database connect ID YYYYYYYY Password is empty Server allow trusted logon flag 0 Ignore trust logon option 0
Symptom
Logon is denied error is in the library server log and customer gets logon failure.
Cause
The Authid used on the bind plan for the CICS transaction program was not defined to CM or RACF and was not configured correctly.
Environment
z/OS and CICS.
Diagnosing The Problem
Look in library server log and find logon denied error.
Resolving The Problem
The fix for this is to -
1) added the AUTHID assigned by the CICS TRAN as both a ICM UID and
ICM DB Connect ID
2) remove ICM Amin privilege from ICM UIDs that will run CICS TRAN;
3) add UserDBConnect or UserDBTrustedConnec privileges ICM UIDs that
will run CICS TRAN.
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Document Information
Modified date:
14 October 2019
UID
swg21980660