Troubleshooting
Problem
A NAS device uses a filer-to-server configuration for backup and restore operations. The NDMP restore fails with "result code 3010"
Symptom
The NAS NDMP restore fails immediately after the process start before the tape mount with the following messages in activity log:
ANR1059I Selective restore of NAS node NAS1, file system /vol/vol2 started as process 17 by administrator ADMIN. Specified files and/or directory trees will be restored to destination /vol/TSMrestore. (SESSION: xxx, PROCESS: yyy)
..
ANR9999D_xxxxxx EndRemoteProc(afremote.c:2688) Thread<8399>: Unexpected result code 3010 for process nn. (SESSION: xxx, PROCESS: yyy)
ANR1078E NAS Restore process 17 terminated - internal server error detected. (SESSION: xxx, PROCESS: yyy)
Cause
The restore object is marked as damaged during a failed restore because of tape drive hardware errors.
Environment
IBM Spectrum Protect
Diagnosing The Problem
Run the "Show Damaged NASPOOLNAME" to show objects that are marked as damaged. For example :
**Damaged files for storage pool NASPOOL, pool id 27
Bitfile: 138895885, Type: PRIMARY
Volume ID: 27014, Volume Name: VOLUME1
Segment number: 1, Segment start: 20, Segment Size: 1504676361856
Volume ID: 27378, Volume Name: VOLUME2
Segment number: 2, Segment start: 1, Segment Size: 3621027974724
NAS1 : /vol/vol2/IMAGE 1
In this output, it shows that an object is damaged on volume VOLUME1 and VOLUME2.
Resolving The Problem
Option 1:Reset the damage flag using the "audit volume fix=no" command. For example :
audit volume volume1 fix=NO
Retry the restore after the object is no longer marked damaged.
Option 2: If there is a copypool for the primary pool, set the primary volumes to damaged and checkin the copypool volume to force the restore to restore from copypool. For example :
update volume VOLUME1 access=damaged
update volume VOLUME2 access=damaged
restore volume VOLUME1 preview=yes
restore volume VOLUME2 preview=yes
The "preview=yes" parameter with the restore volume command will identify the needed copy pool volumes.
Use "checkin libv" command to check in the needed copypool volumes and then update thecopypool volumes access to READonly. For example :
UPDATE volume VOLNAME access=READONLY
Retry the restore command.
Note:
If the object continues to be marked as damaged after receiving certain hardware errors, for example errors with specific tape drives, update the problem tape drives to offline to prevent the hardware issue an retry the restore operation.
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Document Information
Modified date:
17 June 2018
UID
swg21975951