IBM Support

"Unable to locate input assembly 'ANB_CaseManagement.dll" error when installing the Counter Fraud Case Management plug-in

Troubleshooting


Problem

When installing the Counter Fraud IBM Case Management plug-in into IBM i2 Analyst's Notebook Premium on the Tools (client) system, you must run the "regasm.exe ANB_CaseManagement.dll /codebase" command as Administrator.

Cause

If you do not run the regasm.exe command as Administrator, the following error message is displayed:

Microsoft (R) .NET Framework Assembly Registration Utility 2.0.50727.8007
Copyright (C) Microsoft Corporation 1998-2004. All rights reserved.

RegAsm : error RA0000 : Unable to locate input assembly 'ANB_CaseManagement.dll'
or one of its dependencies.

Workaround

Ensure the logged-in user has write access to the components directory by specifying the complete path to the ANB_CaseManagement.DLL as shown:

.NET 4.0 C:\windows\microsoft.net\framework\v4.0.30319\regasm.exe ANB_CaseManagement.dll /codebase
.NET 2.0 C:\windows\microsoft.net\framework\v2.0.50727\regasm.exe ANB_CaseManagement.dll /codebase

[{"Product":{"code":"SSXJFX","label":"IBM Counter Fraud Management"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"--","Platform":[{"code":"PF033","label":"Windows"},{"code":"PF016","label":"Linux"}],"Version":"1.5.0.5","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
28 January 2022

UID

swg21974508