Troubleshooting
Problem
User launches the main Controller client (CCR.EXE). User clicks the green 'X' (to launch the Controller link). Excel starts to load. After a few seconds, an error appears.
Symptom
Error Launching menu item "Controller Link"
Error Details
Cannot run the macro 'cc.CompareDb'. The macro may not be available in this workbook or all macros may be disabled.
Cause
There are several possible causes for this error.
- TIP: For more examples, see separate IBM Technote #1971878.
This Technote specifically relates to the scenario where the cause is that the Controller Excel-add-in has not registered itself 100% properly.
Example:
In one real-life customer example, the 'COM-Add-in' called 'Cognos Controller Link for Microsoft Excel' had not registered correctly, so it was set to 'Inactive':
[Although the 'Excel-Add-In' called the same name had correctly become active].
When looking at the COM-Add-Ins, the item 'Cognos Controller Link for Microsoft Excel' was unticked:
Also, when looking at the Excel-Add-Ins, there was a strange/errant 'Adxloader.Controller.Excellink' entry:
Resolving The Problem
Re-register the Controller Excel link correctly.
Example:
In one real-life customer example, the solution was to:
1. Launch Microsoft Exce
2. Click "File - Options"
3. Click section 'Add-ins'
4. Change the 'Manage' choice to 'Excel-Add-Ins' and click 'Go'
5. Click on 'Adxloader.Controller.Excellink':
6. Choose 'Yes' to delete this from the list.
7. Change the 'Manage' choice to 'COM-Add-Ins' and click 'Go'
8. Tick the box next to 'Cognos Controller Link for Microsoft Excel'
9. Click OK
10. Close all Excel.exe sessions
11. Test.
Related Information
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Document Information
Modified date:
15 June 2018
UID
swg21973528