IBM Support

History file timestamp doesn't match db2diag.log entry for log files

Question & Answer


Question

Why is the log archival timestamp in the history file different from the db2diag.log entry?

Cause

The history file and db2diag.log are not reporting for the exact same activity in this instance.

Answer

This actually occurs because the starting timestamp in the db2history file is not for the beginning of the log archiving process. With a log file, its history entry is inserted when the log file gets created, and its status location/end timestamp are updated when the log file is archived (if archiving is enabled).

[{"Product":{"code":"SSEPGG","label":"Db2 for Linux, UNIX and Windows"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"DB2 Tools - db2diag.log","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"10.1;10.5;9.7;9.8","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
16 June 2018

UID

swg21969628