IBM Support

Calendar Days Not Populating .

Troubleshooting


Problem

The Customer is using cc.fgetval function to populate the calendar days. When a "Run Report" is ran, the values in those fields is 0 BUT when 'F9" is pressed, it updates.

Cause

This has been identified as a product defect under APAR PI50607

Resolving The Problem

Workarounds:
Workaround1: Run F9 after Run Report


Workaround 2: Change the formula for days to uppercase and save (this will solve the problem permanently) as example below
Change formula for days from
=cc.fGetVal($C$2,-2,"ytd","ac","global",,,"lc",99525,,,,,,"all","t","all","t")
To uppercase letters
=cc.fGetVal($C$2,-2,"YTD","AC","GLOBAL",,,"LC",99525,,,,,,"ALL","T","ALL","T")

[{"Product":{"code":"SS9S6B","label":"IBM Cognos Controller"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Controller","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.2.1","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg21968900