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The "Upgrade to the latest version of IBM License Metric Tool 9.x" fixlet is not reporting as relevant for some reason.

Question & Answer


Question

The "Upgrade to the latest version of IBM License Metric Tool 9.x" fixlet is not reporting as relevant for some reason.

Cause

The "Upgrade to the latest version of IBM License Metric Tool 9.x" fixlet from "IBM License Reporting (ILMT) v9" site is normally a recommended way to upgrade the ILMT server to the latest version. The fixlet will download the installer package and perform the upgrade on the ILMT server.

For unknown reason, this fixlet is expecting to be relevant but it is not showing as relevant.

Answer

The best way to diagnose is to find out what relevance statements are defined inside this fixlet.

1) Click on this fixlet and go to Details tab. Under Relevance section, there will be a few relevance statements defined. See below as example.








2) All relevance statements must be evaluated on a target with a return value of "True" in order for the fixlet to become relevant for that target. Try scanning thru each relevance statements and understand what it is looking with each conditions.

3) If having trouble, use the "QnA" tool called Fixlet Debugger provided by Bigfix. This tool is installed by default if IEM server is running on Windows OS.



The latest version of this tool can be downloaded from this link below and then install it on the BESClient where ILMT Server component is installed.



Note: QnA Tool is installed by default on BESClient running on Unix platform located in /opt/BESClient/bin folder.





4) Run the QnA Tool on the BESClient in question and check the results of each relevance statements defined inside the "Upgrade to the latest version of IBM License Metric Tool 9.x" fixlet . See below.

For Windows:


For Unix:

Run /opt/BESClient/bin/qna and Q: will be displayed. See below.




then paste the relevance statements at the Q: prompt and hit Enter key.

The result will be displayed under A:.

If the value is returned as "True", all conditions defined in the relevance statements are met. Then move on to the next relevance statements until the value is returned as "False".

For this exercise purpose, the Relevance 3 returns "False" value due to one of the condition is not met.


Unix:




Reviewing each conditions and find out missing the "LMT_Server_Path" setting on the BESClient where ILMT Server is installed.

5) Back to IEM Console | Computers | locate the server with ILMT Server installed. Check the Summary tab | Client Settings section and verify the "ILMT_Server_Path" setting is existed or not. In this case, it does not exist.





6) If the setting is missing for unknown reason, click on Edit Settings and re-add the setting back. See below.








7) After a minute or so later, the "Upgrade to the latest version of IBM License Metric Tool 9.x" fixlet should be now relevant on the target where ILMT Server is installed.

Note: all relevances defined in the fixlet MUST return a value of "True" before it becomes relevant for any applicable computers. Similar steps can be used for troubleshooting other fixlets as well.

[{"Product":{"code":"SS8JFY","label":"IBM License Metric Tool"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"--","Platform":[{"code":"PF016","label":"Linux"},{"code":"PF033","label":"Windows"}],"Version":"9.0;9.0.1;9.1;9.2","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
26 April 2021

UID

swg21968177