IBM Support

ANS1903W error during client deployment

Troubleshooting


Problem

An attempt to perform a client deployment may fail with an ANS1903W error.

Symptom

The scheduled event completes successfully, however ANS1903W is logged against the postschedulecmd.

09/29/2015 09:10:03 --- SCHEDULEREC STATUS BEGIN
09/29/2015 09:10:03 Total number of objects retrieved: 139
09/29/2015 09:10:03 Total number of objects failed: 0
09/29/2015 09:10:03 Total number of bytes transferred: 501.52 MB
09/29/2015 09:10:03 Data transfer time: 1,855.38 sec
09/29/2015 09:10:03 Network data transfer rate: 276.79 KB/sec
09/29/2015 09:10:03 Aggregate data transfer rate: 273.76 KB/sec
09/29/2015 09:10:03 Elapsed processing time: 00:31:15
09/29/2015 09:10:03 --- SCHEDULEREC STATUS END
09/29/2015 09:10:03 --- SCHEDULEREC OBJECT END TEST7123 09/29/2015 07:37:53
09/29/2015 09:10:03 --- SCHEDULEREC STATUS BEGIN
09/29/2015 09:10:03 --- SCHEDULEREC STATUS END
09/29/2015 09:10:03
Executing Operating System command or script:
"..\IBM_ANR_WIN\V7123\deployclient.bat schedule=schedule_name autodeploy=noreboot server=9.52.181.60 port=1500 node=TEST"
09/29/2015 09:10:03 Finished command. Return code is: 1
09/29/2015 09:10:03 ANS1903W The POSTSCHEDULECMD command failed.
09/29/2015 09:10:03 Scheduled event 'TEST7123' completed successfully.
09/29/2015 09:10:03 Sending results for scheduled event 'TEST7123'.
09/29/2015 09:10:03 Results sent to server for scheduled event 'TEST7123'.

Cause

The schedule definition incorrectly specifies a postschedulecmd when a postnschedulecmd should be used. This will only occur when the client deployment configuration is performed manually, using the Administration Center to perform the deployment configuration will correctly specify a postnschedulecmd.

Diagnosing The Problem

Review the dsmsched.log for the output shown above.

Resolving The Problem

Update the schedule definition to use the postnschedulecmd option instead of the postschedulecmd option.

[{"Product":{"code":"SSGSG7","label":"Tivoli Storage Manager"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"Client","Platform":[{"code":"PF033","label":"Windows"}],"Version":"All Supported Versions","Edition":"","Line of Business":{"code":"LOB26","label":"Storage"}}]

Product Synonym

TSM

Document Information

Modified date:
17 June 2018

UID

swg21967773