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Mirroring fails with fatal communication error java.io.IOException Packet loss detected

Troubleshooting


Problem

Mirroring fails with a fatal communication error. However, a subscription can be restarted successfully.

Symptom

An error in comms trace file located in <CDC_installation_dir>/instance/<instance_name>/log/comms/ directory.
java.io.IOException Packet loss detected

Cause

IDR CDC detected packet loss. That means messages may be getting fragmented when arriving at the target with time delay between fragments. At some point, the time to complete a read exceeds the timeout value of 30 seconds (default value for LINK_CYCLE_TIMEOUT) . If no part of a message was read, IDR CDC tries and reads again. However, if part of a message was received before the timeout, then this is used as an indication of significant delays and potential network problems which lead IDR CDC to close the connection seen as packet loss.

Diagnosing The Problem

Try enabling sniffer trace from the target host and analyze them for possible delays at the time of failure, as well as the general condition of the TCP streams for IDR CDC connections (TCP window, retransmissions, latency, lost packets, checksum errors, etc.).

Resolving The Problem

As a workaround to reduce the frequency of this type of failures increase the timeout value (for example, 120 seconds) in the [SETTING] section of this configuration file: <CDC_installation_dir>/instance/<instance_name>/log/conf/comms.ini

[SETTING]
LINK_CYCLE_TIMEOUT=120

[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSTRGZ","label":"InfoSphere Data Replication"},"ARM Category":[{"code":"a8m0z000000cwbTAAQ","label":"CDC->Troubleshooting->Troubleshooting network and connectivity issues"}],"ARM Case Number":"","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Version(s)","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
12 June 2020

UID

swg21902909