IBM Support

Error BMXAA4129E and BMXAA6695E in VMMSYNC

Troubleshooting


Problem

BMXAA4129E - Record already exists for E-mail=user@ibm.com

Symptom

When VMMSync cron task runs, following error is observed in SystemOut.log
 
BMXAA6695E - The MBO could not be batch validated for object EMAIL. 
The error is EMAILADDRESS. Ensure that the object exists in the
maxobject table. Check the log files in the home directory to
determine the cause and source of the error.
psdi.util.MXApplicationException: BMXAA4129E - Record already 
exists for E-mail=user@ibm.com. Ensure that the key value for
the given record is unique.

Cause

If user does not have email record in Active Directory, do not put a dummy value, for example, N/A or No.

Resolving The Problem

Update email address for the user in LDAP and make sure the value is unique. Maximo does not allow duplicate of email address.

[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSLKT6","label":"IBM Maximo Asset Management"},"ARM Category":[{"code":"a8m0z0000001iYjAAI","label":"Crontask"}],"ARM Case Number":"","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"7.5.0;7.6.0;7.6.1","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
05 August 2020

UID

swg21701552