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Tivoli Workload Scheduler Upgrade from versions 8.5.x/8.6 to 9.1/9.2/9.3

Question & Answer


Question

Tivoli Workload Scheduler Upgrade from versions 8.5.x/8.6 to 9.1/9.2 Upgrade procedure and known problems and limitations. This Technote contains known issues and workarounds for the Dynamic Workload Console and Tivoli Workload Scheduler version 9.1 and 9.2 fresh install and Upgrade.

Cause

Upgrade documentation:

TWS 8.5.1 MDM BKMDM could be upgrade to TWS 9.2 FP2 and higher.


TWS 8.5.1 MDM BKMDM could be upgrade to TWS 9.3 fp1 and higher.


TWS 9.2 documentation is also updated with support of upgrade from releases 8.5.x: http://www-01.ibm.com/support/knowledgecenter/SSGSPN_9.2.0/com.ibm.tivoli.itws.doc_9.2/distr/src_pi/awspimst_welcome.html


Database considerations:
When planning a parallel upgrade of the master to Tivoli Workload Scheduler version 9.2 or version 9.1, consider that Tivoli Workload Scheduler versions 9.1 and 9.2 now support Oracle 12c level during the upgrade.

Tivoli Workload Scheduler version 9.2 now supports DB2 9.7.

Known problem for both TWS and TDWC 9.2 on Red hat 7:

See technote

http://www.ibm.com/support/docview.wss?uid=swg21920404


Known problems for the Dynamic Workload Console:
The following are known problems for the Dynamic Workload Console:

Technote reference #1964202::

How Connect TDWC 9.3 to TWS Engine 8.6 or 9.x
D
DWC 9.3 did not connect to TWS engine lower then 9.3.

Technote reference #1330190: http://www-01.ibm.com/support/docview.wss?uid=swg21330190
Installation Manager graphical environment issues on Solaris, Linux, AIX. The Installation Manager, based on the Eclipse Rich Client Platform architecture, requires specific graphical libraries and versions to work properly.

Technote reference # 1691416:
http://www-01.ibm.com/support/docview.wss?uid=swg21691416
"tdwcUpgrade.sh fails with CTGWA2183E"

Technote reference # 1691800

"TDWC v9.x WebSphere service not created during install on Windows "

http://www.ibm.com/support/docview.wss?uid=swg21691800

Problem: IV68257

Symptom:
Installation of the Dynamic Workload Console version 9.1 Fix Pack 1 fails with the following message: /opt/app/IBM/TWAUI/TDWC/xml/tdwcTargets.xml:730

Cause:
This problem occurs if there is more than one "node" on a JazzSM profile.
For example, the Apache Web Server was installed on top of the JazzSM profile.
A problem can occur with the Dynamic Workload Console Version 9.1 GA, 9.2 GA, and fix pack installations.

Solution:
Uninstall the Apache Web Server or any other Web Servers and check that the following folder contains only one sub-folder:
<JAZZSM_PROFILE>/config/cell/<CELL_NAME>/nodes
It will be fixed in version 9.1 Fix Pack 2 and version 9.2 Fix Pack 2


Problem: IV69069

Symptom:
The Dynamic Workload Console installation can fail with the following error, during the JazzSM profile restart:

JVMJ9GC019E -Xmn too large for -Xms
JVMJ9VM015W Initialization error for library j9gc26(2): Failed to initialize
Error: Could not create the Java Virtual Machine.
Error: A fatal exception has occurred. Program will exit.

Cause:
If the Xmn value in the Dynamic Workload Console server.xml file was set with a value higher than 256 (that is, the default for the Dynamic Workload Console), then the WebSphere Application Server is unable to start.

Solution:
Edit the Xmn value in the server.xml file and set a value lower than 256. Then, restart the installation.
It will be fixed in version 9.1 Fix Pack 2 and version 9.2 Fix Pack 2


Problem: Installation on Linux crashes

Symptom:
Applying the Dynamic Workload Console version 9.2.0 Fix Pack 1 on the master domain manager on Red Hat Enterprise Linux, 6u6 hangs.

Cause:
The operating system libraries are not compatible with Installation Manager.

Solution:
Append the following lines:
-Dorg.eclipse.swt.internal.gtk.useCairo=false
-Dorg.eclipse.swt.internal.gtk.cairoGraphics=false

to the following files:
<DWC_92_FP1_INSTALL_MEDIA>/iim/install.ini
<DWC_92_FP1_INSTALL_MEDIA>/iim64/install.ini

If this does not work, it might be necessary to add the same lines in
the following files:
/opt/IBM/InstallationManager/eclipse/IBMIM.ini
/opt/IBM/InstallationManager/eclipse/launcher.ini

It will be fixed in version 9.1 Fix Pack 2 and version 9.2 Fix Pack 2


Problem: IV69166

Symptom:
When running Tivoli Workload Scheduler version 9.2 installation with IBM Installation Manager version 1.8, the following error is raised:

java.lang.IllegalAccessError
<stack>com.ibm.tws.panels.UserConfigurationPanel.verifyComplete(
Unknown
Source)</stack>

Cause:
Some compatibility problems can occur with Installation Manager version 1.8.

Solution:
Run the installation using IBM Installation Manager version 1.7.

It will be fixed in version 9.1 Fix Pack 2 and version 9.2 Fix Pack 2.

L3 can provide an efix.


Problem: Server name problems

Cause:
Server name specified during the 8.x installation must be in synch with the name specified during the 9.x installation.

Solution:
Before proceeding with the upgrade of the Dynamic Workload Console from either version 8.5.x or 8.6. to version 9.1, be aware of the problems related to the value of the server name you specify when providing the WebSphere Application Server profile configuration information during a fresh installation of the Dynamic Workload Console.To ensure a successful upgrade,the value you specify for the server name during the installation of the version 9.x instance must be the same as the value of the version 8.x instance. To verify this value read the following:

  • Upgrading from version 8.5.x
    When installing the new version 9.1 instance, the default server name proposed by the installation is server1, defined in the Core Services in Jazz for Service Management - WebSphere Application Server profile configuration. You must change this default value to correspond exactly to the value of the server name specified for the 8.5.x instance. You can verify this value by checking the name in place of twaserver<n> in the following path:
    <TWS_home_directory>/eWAS/profiles/twaprofile/config/cells/DefaultNode/
    nodes/DefaultNode/servers/twaserver<n>

    where, twaserver<n> is the hardcoded server name used by the installation, <n> representing an integer.
  • Upgrading from version 8.6
    When installing the new version 9.1 instance, the default server name proposed by the installation is server1, defined in the Core Services in Jazz for Service Management - WebSphere Application Server profile configuration. This is also the default value proposed when you installed the version 8.6 instance. If you maintained this value, then the values in the two instances (8.6 and 9.1) are aligned and no changes are necessary. However, if you used a value different from the default value when you installed the version 8.6 instance, then you must necessarily change the default value proposed during the version 9.1 installation to match the version 8.6 instance. You can verify the value of the server name by checking the name in the place of server1 in the following path:
    <TWS_home_directory>/eWAS/profiles/twaprofile/config/cells/DefaultNode/
    nodes/DefaultNode/servers/server1

Problem: IV76697

Symptom:
Error connecting DWC and Engine after upgrade from 8.5.x or 8.6 to 9.x, the error is present also when upgrading the TDWC only.

The error can occurs when:

TDWC is configured in a shared instance with the master
or
Single Sign on with the master and using the same Orb port.

Cause:
Performing an upgrade from TDWC 8.x to DWC 9.x you need to make a parallel migration where the old TDWC profile is imported into the new DWC. Ports values remain the same as fresh install of new DWC but the OrbServerId () is overwritten with the old value causing single sign on problems because server and DWC now in separate instance have the same value. The installation value for the OrbServerId is equal to the Orb port value.


Solution:

In the DWC server.xml
(JazzSM/profile/config/cells/JazzSMNode01Cell/nodes/JazzSMNode01/server1)
you can found the following:
<properties xmi:id="Property_1433430047306"
name="org.omg.CORBA.ORBServerId" value="31122"/>
but the 31122 is
the port ORB of the engine.

The user needs to replace it.

The user needs to get the good value from the field called:
ORB_LISTENER_ADDRESS port that is found into
the
serverindex.xml
(JazzSM/profile/config/cells/JazzSMNode01Cell/nodes/JazzSMNode01)
<specialEndpoints xmi:id="NamedEndPoint_1183122129642"
endPointName="ORB_LISTENER_ADDRESS"><endPoint
xmi:id="EndPoint_1183122129642" host="sldtws0273.saq.qc.ca"
port="16320"/>

that is the 16320.





Known Tivoli Workload Scheduler problems :


Technote reference #1330190: http://www-01.ibm.com/support/docview.wss?uid=swg21330190
Installation Manager graphical environment issues on Solaris, Linux, AIX. The Installation Manager, based on the Eclipse Rich Client Platform architecture, requires specific graphical libraries and versions to work properly.

Technote reference #1996703
http://www.ibm.com/support/docview.wss?uid=swg21996703
Issue running complex commands on Windows FTAs
All jobs do not run if you define a job to run two or more Windows commands, or .CMD files, separated by the ampersand (&) character. Only the first command in the chain is executed and the second command is ignored.

Technote reference #1653208
http://www-01.ibm.com/support/docview.wss?uid=swg21653208
Although the technote refers to zCentric installation issues, the issue can also occur with any Tivoli Workload Scheduler version 9.x installion on Windows with Security settings.

Technote reference #1700440

http://www-01.ibm.com/support/docview.wss?uid=swg21700440

The issue could be caused by SELinux enabled. As it is very restrictive, cannot allow root to change permissions on files and then TWS 9.x installation can fails.


Database considerations when upgrading
When upgrading your database to version 9.2, if you have a heavy workload running in your environment, you might have to review the database node configuration and tuning. To avoid performance issues, refer to the IBM Tivoli Workload Scheduler V 9.1 Capacity Planning Guide. The recommendations in this document also appy to V9.2 of the product.



Problem: Direct Upgrade of Master from 8.5.x to TWS 9.1 fails using IM 1.6.3.1 and higher level

Symptom:

When selecting the directory where TWS 8.5.1 is installed the IM generates error
messages

AWSJIM101E You Specified an incorrect Websphere Location.
Specify a valid Websphere location.


Solution:
Contact TWS L3 for fix.


Problem :Direct Upgrade of Master from 8.5.x to TWS 9.1 fails using IM 1.6.3.1 and higher level (defect 133377)

Symptom:
The following errors were generated while installing.
AWSJIM005E: The value you specified in the field "user.isSilentUpgrade" is not Boolean (true or false).

Explanation:

User Action: Specify "true" or "false".

Solution:

Contact TWS L3 for fix.


Problem: IV81480 TWS 9.x upgrade can overwrite some TWS customized files.

Symptom:
After TWS 9.x upgrade some files as:
- StartUp
- tws_env.sh
- tws_env.csh
- jobmanrc
- TWSCCLog.properties

can be overwritten.

Customer can get them from the backup directory created under /tmp or %TEMP% as for eg:


tmp/tws92fp2UpgradeBackup/<number>/instance_bck/



Solution:

Apar will be fixed into TWS 9.1 fp4 TWS 9.2 FP3 TWS 9.3 fp2.




Problem: Installation crashes when installing the agent
When installing Tivoli Workload Scheduler version 8.6 or later, the installation might crash when installing the agent because of a known problem related to the McAfee virus scan. Refer to the McAfee Knowledge Center for cause, solution and workaround:

https://kc.mcafee.com/corporate/index?page=content&id=KB71660&actp=search&viewlocale=en_US&searchid=1313422826655


Problem: IV69069

Symptom:
The Dynamic Workload Console installation can fail with the following error, during the JazzSM profile restart:

JVMJ9GC019E -Xmn too large for -Xms
JVMJ9VM015W Initialization error for library j9gc26(2): Failed to initialize
Error: Could not create the Java Virtual Machine.
Error: A fatal exception has occurred. Program will exit.

Cause:
If the Xmn value in the Dynamic Workload Console server.xml file was set with a value higher than 256 (that is, the default for the Dynamic Workload Console), then the WebSphere Application Server is unable to start.

Solution:
Edit the Xmn value in the server.xml file and set a value lower than 256. Then, restart the installation.
It will be fixed in version 9.1 Fix Pack 2 and version 9.2 Fix Pack 2


Problem: IV69005

Symptom:
The Tivoli Workload Scheduler agent installation or uograde, starting from 9.1 and later, can fail if using a Company Name parameter with blanks at installation time.

twsinst output:
ACTION STEP: AWSFAB063I Install engine package
EXIT VALUE: 1
FAILED:
******************************
AWSFAB035E The installation has failed. For more details see the log file: /tmp/TWA/tws91/twsinst_LINUX_X86_64_twsuser^9.1.0.00.log.
******************************

packageDeploy log:

++ ACTION_TOOL_RET_COD=7

Solution:
Remove the blank space from the Company Name from the command line during the fresh install or remove the field from the globalopts during the upgrade phase.
It will be fixed in version 9.1 Fix Pack 2 and version 9.2 Fix Pack 2


Problem: IV68414

Symptom:
Starting from version 9.1, the AS400 agent installation does not install the Common Inventory Technology (CIT) package correctly.
This causes JobManager not to work.

Solution:
Install the CIT package manyually:
1- Access the folder <IMAGE_DIR>/TWS_IBM_I/TWS/IBM_I/CIT
2- Run the following commands:
CITLIB=QTIVCIT
CIT_INSTALLER="wcitinst_os400"
CIT_SPB_NAME="CIT.spb"
export CITLIB
export CIT_INSTALLER
export CIT_SPB_NAME
# create cit library
system "crtlib QTIVCIT"
# create empty savf
system "crtsavf crtlib/wcitinst"
# replace the savf with installation wcitinst
system "CPYFRMSTMF FROMSTMF('$CIT_INSTALLER')
TOMBR('/QSYS.LIB/${CITLIB}.LIB/WCITINST.FILE') MBROPT(*REPLACE)"
# extract wcitinst.pgm from savf
system "RSTOBJ OBJ(WCITINST) SAVLIB(${CITLIB}) DEV(*SAVF)
OBJTYPE(*PGM) SAVF(${CITLIB}/WCITINST) RSTLIB(${CITLIB})"
# install cit
system "CALL PGM(${CITLIB}/WCITINST) PARM('i' 'TWS' '-s'
'$CIT_SPB_NAME' '-d' '${CITLIB}')"

It will be fixed in version 9.1 Fix Pack 2 and version 9.2 Fix Pack 2


Problem: IV69128

Symptom:
The maximum length of the Oracle Net Service name is limited to nine characters in the Tivoli Workload Scheduler installation.

Solution:
To remove the "net service name" limitation, add the following line to the bottom of one of the files that follow, depending on how you are installing:
-DskipValidationClasses=
com.ibm.tws.validator.OracleNetServiceNameValidator

If you are installing running setupTWS.sh or setupALL.sh:
(Installation wizard)
--------------------------------------------------------
- <TWA92_INSTALLATION_MEDIA>/iim/install.ini

If you are installing running IBMIM:
------------------------------------
- <INST_MANAGER_INSTALL_PATH>/eclipse/IBMIM.ini

If you are installing running Launcher:
----------------------------------------
- <INST_MANAGER_INSTALL_PATH>/eclipse/launcher.ini

Solution:
It will be fixed in version 9.1 Fix Pack 2 and version 9.2 Fix Pack 2


Problem: IV69167

Symptom:
9.1 Fix Pack 1 fails. AWSFAB028E THE SUPPLIED PORT NUMBER IS NOT IN THE
RANGE 1 - 65535

Cause:
When attempting to upgrade a Linux Tivoli Workload Scheduler agent with FIPS enabled from version 8.6 to version 9.2, the upgrade fails. This does not seem to be an issue when upgrading Windows systems.

Workaround:
Change the port value to 1.

Solution:
It will be fixed in version 9.1 Fix Pack 2 and version 9.2 Fix Pack 2


Problem: IV69152

Symptom:
When updating a master domain manager to version 9.1 Fix Pack 1 or to version 9.2 Fix Pack 1, the Installation might retrieve the db2 service name incorrectly.
The installation is not able to complete.

Cause:
The installation finds more than an occurrence of the service name in the /etc/services file.

Solution:
It will be fixed in version 9.1 Fix Pack 2 and version 9.2 Fix Pack 2


Problem: Installation on Linux crashes

Symptom:
Applying the Dynamic Workload Console version 9.2.0 Fix Pack 1 on the master domain manager on Red Hat Enterprise Linux, 6u6 hangs.

Cause:
The operating system libraries are not compatible with Installation Manager.

Solution:
Append the following lines:
-Dorg.eclipse.swt.internal.gtk.useCairo=false
-Dorg.eclipse.swt.internal.gtk.cairoGraphics=false

to the following files:
<DWC_92_FP1_INSTALL_MEDIA>/iim/install.ini
<DWC_92_FP1_INSTALL_MEDIA>/iim64/install.ini

If this does not work, it might be necessary to add the same lines in
the following files:
/opt/IBM/InstallationManager/eclipse/IBMIM.ini
/opt/IBM/InstallationManager/eclipse/launcher.ini

It will be fixed in version 9.1 Fix Pack 2 and version 9.2 Fix Pack 2


Problem: IV69166

Symptom:
When running Tivoli Workload Scheduler version 9.2 installation with IBM Installation Manager version 1.8, the following error is raised:

java.lang.IllegalAccessError
<stack>com.ibm.tws.panels.UserConfigurationPanel.verifyComplete(
Unknown
Source)</stack>

Cause:
Some compatibility problems can occur with Installation Manager version 1.8.

Solution:
Run the installation using IBM Installation Manager version 1.7.

It will be fixed in version 9.1 Fix Pack 2 and version 9.2 Fix Pack 2.

L3 can provide an efix.



Problem: Failure in migrating/fixpack installing Tivoli Workload Scheduler version 9.1 to version 9.x on Oracle partitioned DB

Cause:
Oracle stores tablespaces information in the following system table:
DBA_TAB_PARTITIONS

Symptom:
During the installation the following error is reported:

AWSJIM018E The product cannot retrieve the Report tablespace name parameter from the Tivoli Workload Scheduler instance you want to upgrade.

Solution:
Fixed in version 9.1 Fix Pack 2, version 9.2 Fix Pack 2, and 9.3 FP2.

Level 3 can provide the fix.

Problem: TWS 9.2 FP1 FTA, twsinst fails
.

TWS Windows FTA version: 9.2 FP1
Windows Server Version: Windows 2008 SP2
Installation Method: twsinst.vbs

Symptom:
The installer log contains a line such as ":
çIBMçtwsqçTWSç_uninstallçACTIONTOOLSçinstallTWSAction.vbs(92, 2)
Microsoft VBScript runtime error: Wrong number of arguments or invalid
property assignment: 'getBitLevel'".


Solution:

Fixed into 9.2 FP2,9.1 FP2.

Problem: Failure in installing fixpack 9.x on top of 9.1 or 9.2 GA and also Master Domain Manager or Dynamic Domain Manager upgrade from previous releases.

Message like this :

Custom operation Backing up files of current Tivoli Workload Scheduler instance in unit com.ibm.tws.server.unix.backupInstance completed: output in xx.log appears.

It will be fixed into TWS 9.1 FP3 and TWS 9.2 fp2.


In this case, the workaround is to:
- Stop all TWA processes
- Remove the contents of the folder:
<TWA_HOME>/TWS/ITA/cpa/temp
E.g. rm -Rf /opt/maestro/TWS/ITA/cpa/temp/

restart the Installation.

Known problems after upgrading Tivoli Workload Scheduler:




Problem: Issue with movejobhistorydata

Sympton:
After upgrading to Tivoli Workload Scheduler 8.6 and higher release the "movejobhistorydata" command is very slow and the performance of the Broker Server can be negatively impacted.

Cause:
Missing index on DWB.JOA_JOB_ARCHIVES.JOA_UPDATE_TIME on DB2 during upgrade

Solution:
Fixed in Tivoli Workload Scheduler version 9.3 GA and Tivoli Workload Scheduler version 9.2 Fix Pack 2 and Tivoli Workload Scheduler version 8.6 Fix Pack 4 and Tivoli Workload Scheduler version 9.1 Fix Pack 2.

Workaround:
Create missing index on DWB.JOA_JOB_ARCHIVES.JOA_UPDATE_TIME and run db2reorg.

Problem : IV55748


Symptom:

TWS 9.1 INSTALLER DOES NOT CREATE TWAINSTANCE PROPERTIES FILES
CORRECTLY.

Cause:

Missing keyword in these properties files cause TWS for Apps
8.6.0 installation to fail at adding its information to
registry. After installation of TWS 9.1 MDM or FTA, "TWS_FIX_LIST_KEY="
keyword is missing from following properties files.


/etc/TWA
twainstance0.TWA.properties.ext
twainstance0.TWA.properties

Workaround:
Add following line to both twainstance properties files.
TWS_FIX_LIST_KEY=

Solution:

Fixed into 9.1 FP2, 9.2 FP2.



Problem: IV66165

Symptom:
After the installation of the Tivoli Workload Scheduler master version 9.1 Fix Pack 1, the directory javaext/eclipse/plugins contains duplicated plugin jar files (the GA version and the Fix Pack 1 version). The same issue occurs when upgrading from version 9.1 to 9.2. This might cause the Fix Pack 1 java code to not be executed.

Workaround:
The workaround of the issue is to remove the GA version jar files and clean up the plugin cache (javaext/eclipse/configuration) and restart the dynamic agent.

Solution:
This issue has been fixed with version 9.1 Fix Pack 2 and version 9.2 Fix Pack 1.


Problem: IV67896

Symptom:
Tivoli Workload Scheduler masters migrated from previous versions to version 9.1 or version 9.2 get errors in ShowsecurityProperties.sh command.

For example,

################################################################
SSL Panel
################################################################
alias=DefaultNode/DefaultSSLSettings
keyFileName=${USER_INSTALL_ROOT}/etc/TWSServerKeyFile.jks
keyFilePassword=*****
WASX7017E: Exception received while running file
"/opt/TWSM/maestro/wastools/jacls/ShowSecurityProperties.jacl";
exception information: com.ibm.ws.scripting.ScriptingException:
WASX7444E: Invalid parameter value "" for parameter "config
id" on command "showAttribute"

Cause:
This is caused by empty/missing properties in the security.xml file.

Workaround:
N/A

Solution:
This will be fixed in Tivoli Workload Scheduler version 9.1 Fix Pack 2 and version 9.2 Fix Pack 2



Problem: IV69804

Symptom:
After installation of fix pack 1 for zCentric the following error occured with r3batch jobs :

2015-02-10 11:33:12.637+01:00 No such file or directory
2015-02-10 11:33:12.637+01:00 CCGFH0032E Property 'fileName' must be a
valid fille path for this platform, but value './../methods/traces' was given.

Cause:
The Tivoli Workload Scheduler Fix Pack installation overwrites some files and changes the permission inside the methods folder which prevents the trace file from being written
inside the traces folder.

Workaround:
Set the \methods\ files and permission 777



Problem: IV70430

Symptom:
TWS STANDARD AGENT SA UNLINKED AFTER JNEXTPLAN WRITER ERROR
After installation of version 9.2 Fix Pack 1 JnextPlan, the Standard Agents (SA) do not link. The following message is reported on the agent:

AWSBCW039E Writer encountered an error opening the
Mailbox.msg file


Solution:
L3 can provide the efix.
Apar fixed into version 9.2 Fix Pack 2 and version 9.1 Fix Pack 2.


Problem: IV70993
AFTER APPLYING 9.2 FP0001 TO MDM, FTA COULD not LINK AFTER RESTART.                                            


Workaround:
Perform link manually.

Solution:
Fixed with version 9.2 Fix Pack 2 and version 9.1 Fix Pack 2.



Technote reference #1653208
http://www.ibm.com/support/docview.wss?uid=swg21646575
Issues related to Vcredist
Windows 1603 error received installing FTA on Windows 2008 server
The vcredist issues listed should also include the following for release 9.x:


The workaround for the vcredist is different in version 9.x. The customer should edit the twsinst.vbs file, and in the methods installLwaSpb and installFtaSpb, replace " -D tws_user=" with " -D execRedist=false -D tws_user=". This forces the installation flow to not run the vcredist installation. This requires that the customer verify that the required MS libraries are already installed on the system.



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Document Information

Modified date:
17 June 2018

UID

swg21700579