IBM Support

"Unable to retrieve usage information" error occurs in the web user interface

Troubleshooting


Problem

You attempt to display hypervisor, instances, and images information using the IBM Cloud Orchestrator Administration user interface. However, it results in various errors including "unable to retrieve usage information.

Symptom

The user interface displays error messages like the following text:

Error: Unable to retrieve usage information
Error: Unable to retrieve limit information
Error: Unable to retrieve floating IP addresses
Error: Unable to retrieve security groups
Error: Unable to retrieve network quota information
Error: Unable to retrieve volume limit information



The following screen shot illustrates the error messages that are displayed in the user interface:

Cause

Local operating system user accounts might have become disabled or passwords might have expired.

Diagnosing The Problem

The openstack-dashboard-error.log file contains HTTP 500 and other errors. For example:

[Tue Mar 24 18:56:47 2015] [error] Recoverable error: The server has
either erred or is incapable of performing the requested operation.
(HTTP 500) (Request-ID: req-4e36fa7a-91da-4285-b94b-fbcf46120568)

Resolving The Problem

Check the following database user accounts on Central Server 1 to determine if their password have expired:

  • db2das1
  • db2inst1
  • db2fenc1

In addition, check all openstack-related accounts on Central Server 1 and the region servers to ensure they are not disabled. For example:
  • nova
  • dash
  • keystone
  • glance
  • ceil
  • neutron
  • cinder
  • heat

[{"Product":{"code":"SS4KMC","label":"IBM SmartCloud Orchestrator"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"User Interface","Platform":[{"code":"PF016","label":"Linux"}],"Version":"2.4;2.4.0.1","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
17 June 2018

UID

swg21700503