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What are the best practices to run the caupgrade wizard to upgrade Case Foundation Case Analyzer from Case Analyzer version 5.1 or earlier?

Question & Answer


Question

What are the best practices to run the caupgrade wizard to upgrade Case Foundation Case Analyzer (CA) from CA version 5.1 or earlier?

Cause

The purpose of this tech note is to provide step-by-step guidance to prepare and run the caupgrade wizard in order to prevent typical problems.

Answer

The caupgrade wizard is documented at the following locations in the IBM Knowledge Center for Case Foundation:

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Overview
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  • The caupgrade wizard performs an in-place upgrade of the CA relational database, and if OLAP integration is enabled, of the OLAP database.
  • In the P8 5.2.x architecture, a domain object called Event Export Store is introduced, which refers to either a Case Analyzer store or a Case History store (which are distinguished by a type property).
  • In the P8 5.2.x architecture, a new Case Foundation component called the SSAS OLAP Connector performs all operations on the Microsoft® Analysis Services database.
  • The caupgrade wizard does the following:
    1. It creates an Event Export Store domain object, which is the Case Analyzer store, in the P8 domain.
    2. It updates the original CA relational database schema.
    3. If OLAP integration is enabled, it configures the SSAS OLAP Connector and rebuilds OLAP if required.
  • If the Content Platform Engine (CPE) is clustered, you do not have to stop any CPE nodes when you run the caupgrade wizard. The upgrade will be processed by a single server instance only. The other CPE nodes will not access the upgraded Case Analyzer store until the upgrade is completed successfully.
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Preparation Before Running the caupgrade Wizard
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  • Make sure the source CA server which you are upgrading meets the minimum required version and patch levels. Refer to the following tech note:

  • http://www-01.ibm.com/support/docview.wss?uid=swg27038057
  • Prepare the CA databases, both relational and OLAP (if OLAP integration is enabled). These databases should hold the CA data from the old CA installation that is to be upgraded.

  • NOTE:
      • The CA databases can either be where they were in the original CA system that you are upgrading, or they can be imported to new database servers.
  • IMPORTANT: make sure that the original CA databases that you are upgrading are backed up!
  • Make a note of the schema name of the CA databases on the database server where you are going to upgrade them.
  • Create the non-XA and XA data sources for the CA relational database above and the corresponding database connection object. (Optionally, the caupgrade wizard allows you to create these. But you can prevent problems with running the caupgrade wizard if you create and test these objects ahead of time.)
  • Chose a name you will use for the new Case Analyzer store. Make sure the P8 domain does not have another Event Export Store (either a Case Analyzer store or a Case History store) with that name already.
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Additional Preparation if OLAP Integration is Enabled
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  • The Case Analyzer store database must be hosted in Microsoft® SQL Server if you want to enable OLAP integration.
  • Install the CA 5.2 SSAS OLAP Connector software, which is a Case Foundation component. It does not have to be configured. The caupgrade wizard will configure it for the new CA 5.2 store it creates.

  • NOTES:
      • The recommended location for the SSAS OLAP Connector software is the Microsoft® Analysis Services server that hosts the CA OLAP database.
      • If you install the SSAS OLAP Connector on a Microsoft® Windows server other than the Microsoft® Analysis Services server, then compatible Microsoft® SQL Server client must be installed on the Case Analyzer SSAS Connector server.
      • The following tech note has a review of Case Foundation software components:

      • http://www.ibm.com/support/docview.wss?uid=swg21673504
      • When installing Case Foundation components, they must be of the same version as the Content Foundation Content Platform Engine (CPE), and the patch levels between Case Foundation and Content Foundation must be compatible. The following tech note provides P8 fix pack compatibility information:

      • http://www-01.ibm.com/support/docview.wss?uid=swg27014734
      • When the CPE is clustered, you only need to install the SSAS OLAP Connector software once. Again, the preferred location is the Microsoft® Analysis Services server that hosts the CA OLAP database. In ACCE, the Case Analyzer store -> OLAP tab will contain the parameters of that single SSAS OLAP Connector installation.
      • When the Microsoft® SQL Server that hosts the CA relational tables is clustered, you only need to install the SSAS OLAP Connector software once. In the caupgrade wizard, you have to specify the parameters of the Microsoft® SQL Server cluster.
  • Make sure the SSAS OLAP Connector is up and running. Once you install Case Foundation, a Microsoft® Windows service “Case Analyzer SSAS OLAP Connector” is created. Make sure it is running.

  • Make sure the RMI port used by the SSAS OLAP Connector is not blocked between the CPE and the SSAS OLAP Connector servers. The default port value is 32771.
  • Check connectivity between the CPE and the SSAS OLAP Connector servers.
  • NOTES:
    • This can be checked by issuing a telnet command from the CPE server machine to the SSAS OLAP connector machine using port 32771. For example, run the following command on the CPE:

    • telnet [SSAS OLAP connector server name] 32771
    • There cannot be a firewall between the CPE and the SSAS OLAP Connector servers.
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Running the caupgrade Wizard
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Sample command to start the caupgrade wizard from the command line:
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    C:\Program Files (x86)\IBM\FileNet\ContentEngine\tools\PE\caupgrade -I C:\Program Files (x86)\IBM\FileNet\ContentEngine\tools\PE\samples\caupgrade_CA_Repository.properties -A cpe_install_directory\data\analyzer.properties -Y ca_upgrade_user+password.
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For details about constructing the correct command on your system, refer to the Knowledge Center documentation:
. Guidelines for Filling Out the Dialogs of the caupgrade wizard
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1.) For a sample of the first dialog, see the next screenshot below. On that screen:
    • In the Case Analyzer store name edit box, enter the name you chose for the new Case Analyzer store. Remember, another Event Export Store store with the same name should not be present in the P8 domain.
    • When upgrading a CA database for CA 5.1 or earlier, choose the Legacy Workflow System radio button under Event source type.
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2.) For a sample of the second dialog, see the next screenshot below. On that screen:
    • In the Database scheme name edit box, enter the schema name of the original CA database tables on the database server where you are upgrading them.
    • Under the Database Connection radio buttons, specify the database connection object and data sources that you created for the original CA relational database that you are upgrading.
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3.) The third dialog box is displayed if OLAP integration is enabled. The third dialog asks for two kinds of information:
    • The edit boxes that have labels starting with 'Database' are prompting for information about the CA OLAP database that you are upgrading.
    • The edit boxes that have labels starting with 'Connector' are prompting for information about the server where the new CA 5.2 SSAS OLAP Connector software is installed.
    For a sample of the third dialog, see the next screenshot below. On that screen:
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[{"Product":{"code":"SSTHRT","label":"IBM Case Foundation"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Case Analyzer","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF016","label":"Linux"},{"code":"PF033","label":"Windows"}],"Version":"5.2.1;5.2.1.1","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
17 June 2018

UID

swg21698281