IBM Support

SiteProtector X-Press Update Server debug logging

Question & Answer


Question

How do you generate debug logging for the SiteProtector X-Press Update Server component?

Cause

The SiteProtector X-Press Update Server is responsible for downloading updates for the SiteProtector components. If an issue with the download occurs, IBM Support might require debug X-Press Update Server logging to investigate the problem.

Important: If the X-Press Update Server is Offline or if you are using a proxy server to reach the internet, use the instructions in Technote 1681064: Gathering SiteProtector X-Press Update Server debug logging .

Answer

Follow these instructions to generate and collect the logs:

Enable udrc logging

  1. Download the udrc.zip file that is attached to this article.
    udrc.zipudrc.zip
  2. Extract the file that is named .udrc into the following directory on the X-Press Update Server machine:
    \Program Files\ISS\SiteProtector\Application Server\webserver\IHS\
    Note: The Windows operating system does not allow users to create a file name starting with a period. Because of this, Support provides the .udrc file to customers in a zip file. Users should not attempt to rename the file because the operating system does not allow it to be changed back to its original form that begins with a period.

Enable X-Press Update Server debug logging
  1. Open the SiteProtector Console and go to the Agent view.
  2. Right-click the X-Press Update Server and click Manage Policy.
  3. Open the Server Settings policy.
  4. Under the Logging section, change the drop-down to DEBUG.
  5. Save and deploy the policy for the changes to take effect.

Recreate the issue
  1. Go to the SiteProtector Application Server machine and restart the SiteProtector Web Server service. Once this completes, restart the SiteProtector Sensor Controller Service. This forces SiteProtector to attempt to download a new catalog file.
    Note: Restarting the SiteProtector Sensor Controller Server briefly causes your components to go into an Unknown state. These will return to an Active state once the Sensor Controller contacts them again.
  2. If you are trying to update a particular component and it is failing, try this now. Allow it to run until the update fails to capture this in the logging. Otherwise, wait at least 5 minutes to ensure that the issue is captured in the logging

Gather the logs, turn off logging, and submit logs to Customer Support
  1. After the issue is recreated, add the following files to a single compressed file:
    \Program Files\ISS\SiteProtector\Application Server\webserver\IHS\htdocs\XPU\UpdateServer.log
    \Program Files\ISS\SiteProtector\Application Server\webserver\IHS\conf\*.xml
    \Program Files\ISS\SiteProtector\Application Server\webserver\IHS\.udout
  2. Delete the .udrc file from the first section and repeat section two changing the logging level back to ERROR.
  3. Restart the following two services:
    SiteProtector Sensor Controller Service
    SiteProtector Web Server

    Important: Failure to follow these steps will result in very large log files, which can lead to disk space issues on the system.
  4. Send the compressed file containing the logs to Support by using Enhanced Customer Data Repository (ECuRep) .

[{"Product":{"code":"SSETBF","label":"IBM Security SiteProtector System"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Xpress Update Server","Platform":[{"code":"PF033","label":"Windows"}],"Version":"3.0;3.1.1","Edition":"","Line of Business":{"code":"LOB24","label":"Security Software"}}]

Document Information

Modified date:
14 April 2021

UID

swg21697055