IBM Support

Guardium STAP is collecting data but request rate and buffer usage reports are empty

Troubleshooting


Problem

You see in the collector GUI->System View->System Monitor->Request Rate shows "No data found". In GUI->Guardium Monitor->Buffer Usage there is no data. There seems to be data coming into the collector, reports show data with a recent timestamp.

Cause

The sniffer buffer usage process is not running. It may have been automatically stopped, for example if the internal database reached 90% full. Even after purging you may need to restart the process.

Resolving The Problem

1. In the CLI check if the database is close to full:

support show db-status used %

If the database is more than 75% full or unusually full for the appliance, you should consider purging more data. See - What can I do if I see my Guardium Appliance getting full?

2. If the database is at a normal size, run the below commands to restart the buffer usage process:



restart stopped_services
restart sniffer_buffer_usage

Wait 1 minute before checking the reports again.

[{"Product":{"code":"SSMPHH","label":"IBM Security Guardium"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Guardium Database Activity Monitor","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"},{"code":"PF035","label":"z\/OS"}],"Version":"10.0;10.0.1;10.1;8.2;9.0;9.1;9.5","Edition":"All Editions","Line of Business":{"code":"LOB24","label":"Security Software"}}]

Document Information

Modified date:
16 June 2018

UID

swg21695696