IBM Support

When Closing BIRT Report User is Logged Out

Troubleshooting


Problem

After closing report window, user gets logged out of Maximo

Symptom

When the user goes back to the Maximo window after closing the report window, the user gets logged out of Maximo.

Cause

This can be caused by an incorrect entry in the mxe.report.birt.viewerurl property.

Diagnosing The Problem

Check the mxe.report.birt.viewerurl property. If the property is the same as the Maximo server url, you will have this issue.

Resolving The Problem

Correct the Viewerurl entry (that is, point it to the Birt Reporting Only Server BROS) or if you are not using a BROS, delete the viewerurl entry, save and live refresh.

For more information, see the BROS section of the Performance Guide Pg 10 https://www-304.ibm.com/support/docview.wss?uid=swg21305031

[{"Product":{"code":"SSLKT6","label":"IBM Maximo Asset Management"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Report Admin","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"7.1.1;7.5;7.6","Edition":"Edition Independent","Line of Business":{"code":"LOB59","label":"Sustainability Software"}},{"Product":{"code":"SSLKT6","label":"IBM Maximo Asset Management"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":" ","Platform":[{"code":"","label":""}],"Version":"","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
17 June 2018

UID

swg21695500