IBM Support

Insufficient authority to init group during 'dsmserv format' command.

Troubleshooting


Problem

Unable to format the Tivoli Storage Manager database to initialize the database and logs.

Symptom

An example of the dsmserv format failure follows :

[tsminst1@xxxxxxxxxxxx]$ /opt/tivoli/tsm/server/bin/dsmserv -u tsminst1 format dbfile=/home/tsminst1/dbdirs.lst activelogsize=65536 activelogdirectory=/tsmdata/actlog archlogdirectory=/tsmdata/archlog archfailoverlogdirectory=/tsmdata/dbback/archfaillog
Insufficient authority to init group.

Cause

Userid issues which could be related to permissions.

Resolving The Problem

There are several reasons why this error can happen but in this case the problem was related to Tivoli Storage Manager Server instance userid. The following commands can be used to resolve the issue.

  1. Run the 'dsmserv -u {userid} format' command from the Tivoli Storage Manager Server instance directory.
  2. Run the 'dsmserv -u {userid} format' without the '-u {userid}' option/value.

For Example:

dsmserv format

[{"Product":{"code":"SSGSG7","label":"Tivoli Storage Manager"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"Server","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Supported Versions","Edition":"","Line of Business":{"code":"LOB26","label":"Storage"}}]

Document Information

Modified date:
17 June 2018

UID

swg21693423