Troubleshooting
Problem
User tries to use any JAVA-related menu item. User receives an error message.
Symptom
FAIL: Could not attach to JVM
Cause
There are many possible causes for the message "Could not attach to JVM".
- TIP: For more examples, see separate IBM Technote #1619105.
This IBM Technote specifically relates to the scenario where the value of 'CCRProxy.options' has been configured with invalid values.
- TIP: For more information about why you would use the file 'CCRProxy.options', see separate IBM Technote #1573307.
Environment
Example:
In one real-life customer example:
- the customer was using a 10.1.0 version of Controller (which only supports 32-bit JAVA)
- the customer's 'CCRProxy.options' file contained:
-Xms2048M
-Xmx512M
The 'XMS' value is the 'starting' memory value, and XMX is the maximum memory. Clearly in this example:
- the starting value is more than the maximum value, which is invalid
- the maximum value is too large (2048), because it is the absolute theoretical maximum memory of 32-bit software. This means that there is no room left for other JAVA-related stack memory.
Resolving The Problem
Modify the 'CCRProxy.options' file to contain valid values.
Example:
In one real-life customer's environment, the following values solved the problem:
-Xms512M
-Xmx1396M
Related Information
[{"Product":{"code":"SS9S6B","label":"IBM Cognos Controller"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Controller","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.1","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]
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Document Information
Modified date:
15 June 2018
UID
swg21693253