IBM Support

Identifying Windows 32-bit and 64-bit systems

Troubleshooting


Problem

How do I determine whether a Windows system is 32-bit or 64-bit?

Cause

IBM MQ 8.0 and later versions are 64-bit products which cannot be installed on 32-bit Windows systems.

Resolving The Problem

Open a Windows Command Prompt and use one of the following two methods to determine whether the Windows installation is 32-bit or 64-bit. The first method uses the Windows Management Instrumentation Command interface while the second uses the systeminfo command:
 

Checking for 32- or 64-bit Windows using WMIC

C:> WMIC OS GET OSArchitecture
OSArchitecture
64-bit

Checking for 32- or 64-bit Windows using SYSTEMINFO

C:> SYSTEMINFO | FIND /I "System Type"

System Type:               x64-based PC

This command may take a minute or more to complete. If it reports an X86-based PC then Windows is 32-bit; if it reports an x64-based PC then Windows is 64-bit.

 
IBM MQ 8.0 and later versions are 64-bit and cannot be installed on 32-bit Windows systems.  A version of the IBM MQ 8.0 client is available for 32-bit Windows systems from the SupportPac MQC8 page, but this is the last MQ client version to support 32-bit Windows systems.  Look for the "Win32" client install image from Fix Central:
 

[{"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Product":{"code":"SSYHRD","label":"IBM MQ"},"Component":"","Platform":[{"code":"PF033","label":"Windows"}],"Version":"All Versions","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
19 November 2019

UID

swg21687382