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How can I clear up IBM TRIRIGA Application Server's cache area?

Question & Answer


Question

I am running IBM TRIRIGA and need to clear up its Application Server's cache area since it seems to be corrupt or I need to certify cache is really refreshed after new EAR file deployment. How can I do that?

Cause

I have just deployed new IBM TRIRIGA EAR file or need to make sure no Application Server cache file is corrupt.

Answer

IBM WebSphere:

If you are using IBM WebSphere as your Application Server product, the temporary files and cache folders are:

1) TEMP folders

ibm\websphere\appserver\profiles\<app server profile>\temp\<node>\<app server>
ibm\websphere\appserver\profiles\<app server profile>\config\temp
(if cluster in place)
ibm\websphere\appserver\profiles\<app server profile>\wstemp
(if any)

Examples:

ibm\websphere\appserver\profiles\ctgappsrv01\temp\ctgnode01\server1
ibm\websphere\appserver\profiles\ctgDmgr01\config\temp
ibm\websphere\appserver\profiles\ ctgappsrv01\wstemp



For more details, please refer to IBM WebSphere dW Answers:


Content and maintenance of temp directories for WebSphere Process Server
http://ibm.co/1Arz0MR

Content and maintenance of the wstemp directory for WebSphere Process Server
http://ibm.co/1EsxFY1


2) LOG folders

It is good to start fresh after clearing the temp and cache folders above, so consider clearing up as well the log folders:

ibm\websphere\appserver\profiles\<app server profile>\tranlog\<cell>\<node>\<app server>
ibm\websphere\appserver\profiles\<app server profile>\logs\<app server>
ibm\websphere\appserver\profiles\<app server profile>\logs\ffdc

Examples:

ibm\websphere\appserver\profiles\ctgappsrv01\tranlog\ctgcell01\ctgnode01\server1
ibm\websphere\appserver\profiles\ ctgappsrv01\logs\server1
ibm\websphere\appserver\profiles\ ctgappsrv01\logs\ffdc

Content and maintenance of the wstemp directory for WebSphere Process ServerContent and maintenance of the wstemp directory for WebSphere Process Server



Stop the server (JVM) and delete the files in the folders above (1 and 2). They will be recreated at server's (JVM's) start up.


Oracle BEA WebLogic

If you are using Oracle BEA WebLogic as your Application Server product, the temporary files and cache folders are:

bea\user_projects\domains\<domain>\servers\<app server>\tmp

Example: bea\user_projects\domains\base_domain\servers\AdminServer\tmp

Log folder is under: bea\user_projects\domains\<domainname>\servers\<servername>\logs\
<servername>.log


Stop the server (JVM) and delete the files in the folders above. They will be recreated at server's (JVM's) start up.


JBOSS 5.1

If you are using JBOSS 5.1 as your Application Server product, the temporary files and cache folders are:

<JBOSS server install>/default/tmp
<JBOSS server install>/default/work


The tmp directory is used for temporary storage by JBoss services. The deployer, for example, expands application archives in this directory.

The work directory is used by Tomcat for compilation of JSPs.

JBOSS 5.1 log folder is where the log files are written. JBOSS uses the Jakarta log4j package for logging and you can also use it directly in your own applications from within the server. Logging is controlled from a central JBOSS conf/log4j.xml file. Its log folder is:

<JBOSS Server install>/default/log

Stop the server (JVM) and delete the files in the folders above. They will be recreated at server's (JVM's) start up.

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Document Information

Modified date:
17 June 2018

UID

swg21685678