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IBM PureData System for Analytics - "replacespu" command fails w/ error: Password authentication failed for user 'ADMIN'

Troubleshooting


Problem

Ran the replacespu command. It failed with the following error: ERROR: Unable to read spu information from nzhw error connecting to database system Password authentication failed for user 'ADMIN'

Symptom

"replacespu" command fails w/ error:
ERROR: Unable to read spu information from nzhw
error connecting to database system
Password authentication failed for user 'ADMIN'

Cause

The replacespu command is failing because it cannot find the correct NZ_PASSWORD.

Environment

Any IBM PureData System for Analytics appliance.

Diagnosing The Problem

If the symptoms above are seen, then follow the fix below to resolve.

Resolving The Problem

Fix: As user nz run the "env" command to get the nzpassword.

Example output:

NZ_PASSWORD=xxxxxxxx

Then as root, run

# export NZ_PASSWORD=xxxxxxxx

Where "xxxxxxxx" is the actual nz password listed by the env command.

After the export command completes the replacespu command should start normally.

[{"Product":{"code":"SSULQD","label":"IBM PureData System"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"--","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"1.0.0","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
17 October 2019

UID

swg21685318