IBM Support

Unable to SETACTIVITY in UCM/OSLC integration in ClearCase when ClearQuest field name uses invalid character in XML tag

Troubleshooting


Problem

In the IBM Rational ClearCase and Rational ClearQuest OSLC-based integration, if ClearQuest field name contains invalid character defined in XML specification, the SetActivity operation will fail.

Symptom

The full error message is as follows:

RMAP7009: CCRC command 'BindActivityRpc' failed:
CCRC WAN Server: Error: Xerces SAXParseWxception: line: 29:
column 6 Message:Expected an attribute name
CCRC WAN Server: Server replied unrecognized XML to client
CCRC WAN Server: Error: The ClearQuest record, 'xxxxx000000xx',
was not found.

Cause

Per W3C specifications, some characters are not valid XML tag, although they are valid characters in the ClearQuest field name. The XML parser is not able to parse the XML coming from ClearQuest server.
http://www.w3.org/TR/REC-xml/#NT-NameStartChar

Resolving The Problem

Remove or replace the invalid characters in the schema and upgrade the database.

Invalid characters include:
!@#$%^&*()+{}|「」¥<>

[{"Product":{"code":"SSSH5A","label":"Rational ClearQuest"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Integrations: IBM","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"7.1.2;7.1.2.1;7.1.2.10;7.1.2.11;7.1.2.12;7.1.2.13;7.1.2.14;7.1.2.2;7.1.2.3;7.1.2.4;7.1.2.5;7.1.2.6;7.1.2.7;7.1.2.8;7.1.2.9;8.0;8.0.0.1;8.0.0.10;8.0.0.11;8.0.0.2;8.0.0.3;8.0.0.4;8.0.0.5;8.0.0.6;8.0.0.7;8.0.0.8;8.0.0.9;8.0.1;8.0.1.1;8.0.1.2;8.0.1.3;8.0.1.4","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
16 June 2018

UID

swg21682003