IBM Support

Diagnosing and resolving ANR8311E with error 16/170 EBUSY failures on drive WRITE

Troubleshooting


Problem

Diagnosing and resolving ANR8311E with error number 16 / 170 (EBUSY) reported by the Tivoli Storage Manager Server during drive WRITE operations.

Symptom

ANR8311E An I/O error occurred while accessing drive DRIVE1 (/dev/rmtX) for WRITE operation, errno = 16.
ANR8311E An I/O error occurred while accessing drive DRIVE1 (mtx.y.z.n) for WRITE operation, errno = 170.

Cause

This is a return code returned to Tivoli Storage Manager by the operating system via the device driver (IBMtape or TSMtape) when attempting to issue a WRITE against an opened device special file. On Unix operating systems, errno 16 means the file was busy, or EBUSY. On Windows operating systems, the errno is 170, but the meaning is the same. This error indicates that the operating system could not satisfy Tivoli Storage Manager's request to issue a WRITE to an opened device.

Most typically this means that the drive or SAN switch is too busy to complete the WRITE operation and has asked for the application to retry the request later.

Resolving The Problem

The Tivoli Storage Manager device driver will automatically retry the operation every 10 seconds up to 90 times before failing the write operation with the ANR8311E. This functionality exists in all currently supported Tivoli Storage Manager device driver code. The IBMtape device driver, however, did not implement similar retry logic until version 12.3.7.0 (released in 12/2011). At 12.3.7.0, 50ms retry logic was introduced up to 4 minutes or 480 times. Upgrading the appropriate device driver to current may resolve the issue.

If this doesn't resolve the error, further investigation at the device driver, SAN (switch), and tape device layers should be completed to determine if the BUSY signal being returned is appropriate or not.
Related information

[{"Product":{"code":"SSGSG7","label":"Tivoli Storage Manager"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"Server","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Supported Versions","Edition":"","Line of Business":{"code":"LOB26","label":"Storage"}}]

Product Synonym

ITSM ADSM TSM

Document Information

Modified date:
17 June 2018

UID

swg21676996