Troubleshooting
Problem
Sign-on terminates and you receive message DFHCE3500 Unable to interpret keyword data when signing onto a CICS Transaction Server for z/OS (CICS TS). This occurs when signing on for the first time after upgrading to CICS TS V5.1. You are using the CA ACF2 signon program.
Symptom
DFHCE3500 Unable to interpret keyword data. Sign-on is terminated.
Cause
Group DFHCOMPF was added to the end of the startup GROUPLIST. This caused the ACF2 definition for transaction CESN to be overridden with the supplied CICS definition within group DFHCOMPF. As a result, ACF2 signon information was unrecognized by the CICS supplied CESN transaction.
Diagnosing The Problem
You can enter the following CICS commands to help you determine if the incorrect transaction definition for CESN is defined in any groups within your CICS region:
- CEMT INQUIRE TRANSACTION(CESN) to display the program CESN is pointing to within your CICS region. IBM CICS programs all start with "DFH".
- CEDA DISPLAY TRANSACTION(CESN) GROUP(*) to display all the groups containing a definition for CESN.
- CEDA DISPLAY LIST(*) G(xxxxxxxx) where xxxxxxxx is the group name(s) returned in the previous command, to display all the group lists containing the group.
Resolving The Problem
Clear the screen, enter transaction CESN, and fill in userid and password on the CICS supplied signon screen. Reference CA Support Request 21827851-01 for additional details.
To prevent this from occurring in the future, remove the group containing the IBM supplied CESN transaction definition from your GRPLIST. Or, put the ACF2 group after the IBM supplied group.
Related Information
Product Synonym
CICS/TS CICS TS CICS Transaction Server
Was this topic helpful?
Document Information
Modified date:
15 June 2018
UID
swg21675620