IBM Support

A NullPointerException occurs with IBM Business Process Manager (BPM) when trying to install an SCA application to a Process Server

Troubleshooting


Problem

You cannot install an SCA application with BPEL content to the Process Server even though the application is not already installed and its artifacts do not exist in the file system. A NullPointerException that is related to getDeployedBPCApplications is reported in the SystemErr.log file.

Symptom

The following symptoms are related to this issue:

  • During the deployment process, the following error and stack are added to the SystemErr.log file for the deployment manager:
    java.lang.NullPointerException
    at com.ibm.bpe.management.application.DMGRDeployedBPCApplicationResolver.getDeployedBPCApplications
     (DMGRDeployedBPCApplicationResolver.java:566)
    at com.ibm.bpe.management.application.DMGRDeployedBPCApplicationResolver.isTemplateAlreadyDeployedOnTarget
     (DMGRDeployedBPCApplicationResolver.java:617)
    at com.ibm.bpe.management.application.DMGRDeployedBPCApplicationResolver.isProcessTemplateAlreadyDeployedOnTarget
     (DMGRDeployedBPCApplicationResolver.java:594)
    at com.ibm.bpe.management.application.TargetHasProcessTemplateNotAlreadyConfiguredRule.verify
     (TargetHasProcessTemplateNotAlreadyConfiguredRule.java:73)
    at com.ibm.bpe.management.application.AbstractDeploymentTask.runVerificationRules
     (AbstractDeploymentTask.java:371)
    at com.ibm.bpe.management.application.AbstractDeploymentTask.performTask
     (AbstractDeploymentTask.java:100)
  • You can see the following warning message in the deployment manager SystemOut.log file, which notes that there is a corrupt application directory:
    NMSV0819W: No deployments directory found for application.  Ignoring application "MyApp.ear".
  • A previous application installation failed, but the configuration workspace was saved rather than discarded. You can determine when the files were created by searching the SystemOut.log file of the deployment manager or node agent for files that are related to the problematic EAR file. For example:
    ADMR0015I: User admin created document cells/my_cell01/applications/MyApp.ear/MyApp.ear.
  • During the original creation process for the problematic directory, you might see an FFDC that is related to com.ibm.ws.management.application.sync.AppDataMgr.updateDeplData with the following exception:
    java.lang.NullPointerException
    at com.ibm.ws.management.application.task.ConfigRepoHelper.getAppDeploymentForApp(ConfigRepoHelper.java:1079)
    at com.ibm.ws.management.application.sync.AppDataMgr.updateDeplData(AppDataMgr.java:489)
    at com.ibm.ws.management.application.sync.AppDataMgr.postProcess(AppDataMgr.java:358)

Cause

When BPEL templates need to be installed for an application, the product first checks the existing installed enterprise archive (EAR) files for applications that contain a previous version of the same template. To accomplish this task, it looks for certain files in the deployments directory for the application. When this directory is missing for any application, a nullpointer exception is thrown, which causes the application installation to fail.

It is possible to save the configuration workspace rather than discard the changes after a failed installation. However, saving the configuration workspace after a failed installation can create a application EAR directory that only contains a few files and is missing the deployments directory. The application EAR directories are located in the
profile_root\config\cells\cell_name\applications\ directory.

Note: The invalid application directory might not be related to the current application that is being installed; it might have been created a while ago.

Resolving The Problem

To resolve this issue, any invalid application directories in the deployment manager configuration need to be removed. These invalid application directories would be located at the following location:profile_root\config\cells\cell_name\applications\



To determine which directories are invalid, you can use one of two following methods:
  • Open the Integrated Solutions Console or administrative console, expand Applications > Application Types, and click WebSphere Enterprise Applications to the list of enterprise applications. Check each directory in the applications folder to see if a matching enterprise application is found in the list.

  • Look for warnings in the SystemOut.log file for the deployment manager that show an invalid directory. For example:
    NMSV0819W: No deployments directory found for application.  Ignoring application "MyApp.ear".



These application directories are missing the deployments folder and did not complete the installation process. Thus, they should be manually removed. For example, in the previous warning, the MyApp.ear directory, which would be associated with the MyApp enterprise application, is invalid and should be removed.



After all of the invalid directories have been removed from the deployment manager, you need to perform a full node synchronization to ensure that the node's configuration matches.

[{"Product":{"code":"SSFTN5","label":"IBM Business Process Manager Advanced"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Application Deployment","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"},{"code":"PF035","label":"z\/OS"}],"Version":"8.5.5;8.5;8.0.1;8.0;7.5.1;7.5","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Product Synonym

BPM

Document Information

Modified date:
15 June 2018

UID

swg21675274